MT300N-V2 WiFi client/station mode


I’ve finally got my hands on an MT300N-V2, but I’m having trouble getting it to connect to WiFi networks at all (which is necessary for my use case - I don’t need it to act as an access point simultaneously or anything, just a client).

I first tried with the clean firmware, but that appeared to be actually missing some parts of the WiFi system, so I then tried with the full 2.263 firmware. That doesn’t seem to be missing anything, but it still won’t work.

I’ve tried to connect from LuCI, which is able to scan for WiFi networks ok, but trying to join one causes a LuCI error (on a page which is blank apart from the error message):

/usr/lib/lua/luci/dispatcher.lua:460: Failed to execute arcombine dispatcher target for entry '/admin/network/wireless/mt7628.network1'. The called action terminated with an exception: /usr/lib/lua/luci/i18n.lua:42: bad argument #1 to 'format' (integer expected, got nil) stack traceback: [C]: in function 'assert' /usr/lib/lua/luci/dispatcher.lua:460: in function 'dispatch' /usr/lib/lua/luci/dispatcher.lua:141: in function </usr/lib/lua/luci/dispatcher.lua:140>
If I then go back into LuCI, I find that it has actually created what looks like the correct configuration changes, it just hasn't applied them (see below with actual network details removed):
wireless.mt7628 wireless.mt7628.disabled=0




firewall.cfg06dc81 wan6 wwan

So if I apply the config changes, it seems like it should then connect, but it still doesn’t. It creates a new interface apcli0, which shows in ifconfig along with the existing ra0, but neither of these ever gets an IP address.

I’ve also tried manually editing the uci wireless config instead of using LuCI (after resetting the firmware back to defaults), and tried adjusting a few of the config settings which seem to be specific to the mt7628 driver, but none of this has made any difference (and part of the problem is that I can’t find any documentation of the settings for this driver). When I check the log of the WiFi router that I’m attempting to connect to, there is no sign of the device ever attempting to associate with it at all (let alone getting as far as requesting an IP address etc).

What am I doing wrong? And is there any documentation of the uci wireless config options for the mt7628 driver available anywhere?


I’ve just found something new. If I reset the firmware to defaults, use LuCI to scan for WiFi networks and attempt to connect, apply the config, and then reboot the device, WiFi association attempts from it then start showing in the log of the router I’m attempting to connect to. But it shows as disassociating and immediately re-associating again every 5 seconds, and there’s no sign of anything else happening such as DHCP requests etc. Also ifconfig on the device still shows RX and TX bytes as 0 on both apcli0 and ra0 interfaces.

I have seen something similar in LuCI when wireless security was not setup right in client mode

I have the same problem. I’ve set up openwrt clients on dozens of routers, but with whatever I try on the MT200N-V2, serial console shows repeated rebooting.

How should client wifi be set up, either with LUCI or the command line?