MT300N-V2 Wireguard wont connect following power outage

We had a power outage today and following that the Wireguard client will no longer connect to my VPS server. On the server I can see that the last connection time was when the power went out.

I’ve tried rebooting the client and also power cycling, but still nothing.

Any ideas where to start with tracking this down. And I’m fully at home poking around a file system via ssh.

3.211 fixed it

That takes me to a blank page.

And just curious, exactly what the issue is. Seems a device like this shouldn’t be affected by non-controlled power outage.


Sorry, just upgrading firmware download website.

You can now search MT300N-V2 and beta from

Well, I’m not sure what’s going on. Today I downloaded the beta you suggested, connected to the Mango, but before uploading the image I tried Wireguard again.
Despite it not being able to connect yesterday, and remaining powered on the whole time, today it connected perfectly.
Grrrrrr. I have worked in both software support and development, which is why I really do hate things like this. Trying to track down an issue when it didn’t work, nothing was changed, and then it did work.

Wireguard, when working as routing, has a problem that may only appear in rare times, e.g. Internet not stable, power outage etc.

3.211 does fixed a bug like this.