MT300N V2 Wrong Password

Hi all, new here.

I’ve scoured this forum and the internet and haven’t quite seen a solution for this issue…

I’m not nearly as technical as most of the folks on here, so forgive me for the layman explanation.

I purchased a new MT300N V2 and was able to connect via WiFi and log into it according to the instructions with no issues upon starting it up.

I set a new admin password, and then went to the internet setup. During this, the router locked up. I disconnected the WiFi and reconnected…from this point I have not been able to connect to it via WiFi. Neither with the default or my password.
I can physically connect into the LAN port with no issues.

I have factory reset the router, reinstalled firmware, and still cannot connect to the router’s WiFi network. Default password does not work.

Always the same “incorrect password”.

Any suggestions would be beyond helpful.

are you sure you factory reset it rather than just reboot it?

There are different functions achieved based on how long you hold the reset button. The LEDs should flash with a different frequency to demnstrate the different options.

Thank you for replying.

100% sure. I did a factory reset from the GUI, same result. I did the factory reset button hold (10sec) from the manual, same result. And finally did the UBoot firmware reinstall. Same result.

I should note that I can see the SSID for the router…both the default and whatever I change it too…I can also change the password successfully and make any config changes I want while connected directly via Ethernet.

Just unable to connect to it wirelessly.

Incorrect password is what I’m going to name my autobiography.