MT300Nv2 won't pass devices to captive portal at hotel

Hi guys,

I’m now using the v2 version of the mango router :slight_smile: I don’t think this has anything to do with my issue…just for clarification.

I’m connecting an ethernet cable to the WAN port of the router in my hotel room but I can’t get the captive portal page for authentication to pop up.

If I plug the LAN cable straight from the wall to my laptop, I get the captive portal page and can authenticate. I even tried spoofing the MAC address of my laptop to the mango…but it still won’t work.

When I connect the mango to ethernet, it shows that it obtains an IP address via DHCP but I just can’t access the captive portal. I think this might be some restrictive stuff the hotel is doing, but I’d appreciate any tips to see if there’s any other configuration options on the mango I can try.

Also, I’ve tried the repeater/wisp function…it will not obtain an IP address at all that way…I know this feature works on the router as I used it last week…so I’m pretty sure it’s just the hotel :frowning:

Any ideas?

Have you tried option rebind_protection ‘0’ ?

I’m not sure how to set up rebind_protection ‘0’ or what that does… unfortunately, I doubt it will do anything…

I called the hotel tech support (Fairfield Inn and Suites, which is a Marriott brand) and they told me they do not allow routers on their network and block them. The tech support person told me I would have to get special permission from the general manager to allow such a device. I’m not going to mess with all of that, so I’m stuck with the open hotel wifi network for this trip.

I normally stay at Hilton properties (Hampton Inn, Home2 Suites) when I travel for business and have been able to use the Mango at those chains successfully. I branched out this time to try something new…I won’t be going back to Marriott properties any time soon.

And I see that you linked to me what rebind_protection is (the contrast on my screen didn’t show that you made it a link). Thanks for that! Should have read the forums deeper :frowning:

Well, I’ll mess around with it a bit…looks like others were successful at Marriott hotel…here’s hoping.

Piling on here to request this feature as a button of some sort in the gui…I currently can’t connect (and stupidly created another thread about these issues - sorry). It’s not completely beyond me to tinker at this level with the router but it’s not something I have the energy to mess with this trip. It would take a little research to just figure out exactly what you guys are all explaining how to do. That’s really been the beauty of these routers though…I don’t spend time messing around with settings and junk in the hotel when I just want to relax/recover/get work done. Having this feature easily available for dummies (like me) would be awesome!

edit - ugh - and submitted this in the wrong thread…it’s getting late…see even more reason I need this to be easy!

In that post I suggested trying to type the url to the portal page directly instead of hoping for a auto redirect. It’s often on the info card in the hotel or you may get it from the laptop when directly plugged in. Save it as a short cut.

It worked for me at the Hampton Inn, not tried it at the Marriots.

@murdock57, don’t even talk with hotel technician. They will always say no. The “option rebind_protection 0” works for me here. I will make this available in the UI.

There is some way to detect if you are using a router other than a device. This is widely used in the universities in China and I never heard the rest of the world used this. But this can also overcome.

Thanks for the additional replies - and sorry for the cross post - I posted in the other thread that I was able to change the rebind protection option with WinSCP and got it to work!

@alzhao, good point about not messing with the hotel techs. Looking forward to a UI option to change the rebind protection in the future! Also, just want to say thanks to you and everyone working on these routers. I was super bummed during this work trip because I had just purchased Splatoon 2 for my switch, and of course, the stupid hotel wifi was doing some restrictive NAT and wouldn’t allow me to connect to server sessions for online play. Once I finally got the rebind protection working, I was able to turn on OpenVPN on the Mango and tunnel back to my home router to let it do the NAT. After that, I was able to kick back and enjoy some much needed down time on a long work trip.

Seriously, this little router is so flexible and adaptable to different situations on the road. I felt like some kind of master hacker when I got around the dumb hotel’s restrictions - and you guys made that possible…and are continually making it easy for semi-dummy folks. I’ve already told other folks about your products (one friend bought 2 routers already) and I set up another one at my parent’s guest house to extend wifi to it. Can’t believe these things work as well as they do and for the price. Please keep up the good work and thank you so much for making this product what it is!

I had a strange situation happen to me at a Crowne Plaza hotel. My AR-300M would not see the SSID of the access point. I could see it on my phone and computer but it was invisible to the router.
I did end up getting online by connecting to a random access point then going in to the advanced settings and changing the random one’s name to the hotel’s SSID.


I’ve never encountered that issue before…

Is that a channel problem? For example, it is using channel 14?

@alzhao - not sure. I did’t think to check that. If I encounter that again I’ll look.

In case you are in the US and your router is configured to operate on channel “auto”, I would advise you to keep the country code of your wifi radio to US as this avoids any possible incompatibility due to wifi channels 12 or 13

And I would strongly advise against that, as you will then not find networks on 12, 13, 14!
In any case, the default for the firmware is US.

Of course, an openwrt router can be configured to use channels 12, 13 or 14 at own convenience. However in North America the risk that a device might not detect your wireless AP remains an issue as mostly all WiFi enabled devices for the US market are configured by default with the FCC standard