Mudi File Sharing Trouble - PC Won't Connect - Mac Will

Hello- Have a new MUDI device. Having trouble with file sharing.

  • Updated device software
  • Using PC Card and internal storage (card is formatted NTSF)
  • Enabled file sharing
  • I am able to access the files sharing without trouble on Mac.
  • Am unable to access file sharing on PC. Tried: \\\ and PC connection throws an error.
  • Happens on internal storage, USB2 memory stick, and PC Card.
  • I am able to connect to other NAS and MT3000 without any problems. Its just the MUDI.
  • Using PC with latest update of Windows 11.

Any help? Thanks!

Have you tried the methods in the link?

Not very helpful and yes, I read those before contacting. Any particular section you’re referring to? Considering I can connect to pretty much any other NAS, Shared Folder, Other Routers, and even other GLiNet devices, where exactly would you point me? Are you talking about this unhelpful section:

  • On the left side of web Admin Panel → APPLICATIONS → File Sharing → File Sharing You can use an external USB storage or a MicroSD card with GL.iNet router, and some models have big internal storage. For sharing the external or internal storage please check out file sharing.
    Or Maybe this unhelpful section:
  • You may be able to access the share via \\\ or smb:// or with GL-modelXXX instead of (eg \\GL-AR750S\ ) in your system’s file explorer. - In this case, does “May be able to access” mean that it only sometimes work? And also, when you try to connect this way in Windows 11, “smb://” it tries to take you to the Microsoft Store.

As you can see, these are instructions, not really good at trouble shooting and they aren’t accurate. If this is telling me to reconfigure Windows 10 and Samba, that also isn’t helpful since I’m Win 11 and I can’t go around to client computers and reconfigure their Samba settings. I’m evaluating these devices to deploy in the field of my company. This is why I have about 4 different GLiNet devices for testing. If I can get these to work, I plan on distributing throughout my company to be used within Large Fortune 500 companies as a consulting device.

So couple thoughts:

  • Sending me a book or all your product’s documents isn’t helpful.
  • The documents need updating
  • The documents also need to reviewed for accuracy
  • The documents don’t seem to be helping in this case because either a) It’s something else or b) It’s hard to find the exact section of an “all company product” set of documents or c) The documents aren’t accurate since they haven’t been updated correctly.

So, how about helping out? What exactly do I need to do to troubleshoot this particular model since pretty much all other devices seem to work without issue.


Found the problem: Just as the docs suggested, I had to enable SMB1 on the client machines. This is not a fix for our circumstances. We’re trying to deploy these thorough our company and I can’t setup training for field people to enable SMB1 on all machines.

The MUDI device is the perfect solution for my company but appears to use the 3.0 firmware. Using the BERYL doesn’t have this problem but I need to cellular Internet sharing capabilities. I’m guessing its a 4.x firmware difference.

Is there a way to load the 4.0 firmware into the MUDI?


BTW: The docs are very complete, but hard to get through. Also, its seems very strange that for a user to use file sharing, they’d have to enable SMB1 on their client machines. I have not attempted method 2 yet (I’m the president of the company and not extremely technical or flush with extra time). Thx!

I followed the instructions for SMB connectivity option 1 and 2. After extensive testing, the only way to get any of our Windows 11 computers to connect to the MUDI is via option 1: Enable SMB1 on all client computers. Tried adding the SMB Min/Max in the template file, but still no luck.

As much as I want this device to work for our company, this will not work. We’d have to go in to all client computers and reconfigure.

Is there any other options I have with the MUDI unit? As I said, the BERYL works fine, but we need this to act as a Hotspot as well. Is there a firmware update, any other software, anything for the MUDI?


Just came around this and have to say: Don‘t even think about enabling SMBv1.

SMBv1 is broken and totally insecure. When you enable it, it’s just a matter of time until the device or the whole company gets hacked.

Never ever enable SMBv1 on a windows device.
It’s disabled by default for a very good reason.