MUDI GL-E750 Cannot connect to device hotspot

My device is only around one week old. I have got a problem that while the device is running normally at night, after I shut it down before I sleep and the next day after I switch it on, I cannot connect to it using wifi. Here I mean I cannot use the wifi on my mobile phone to find the device’s hotspot, not to mention connecting it.

I spend the last whole day trying to figure out what happened without success, because I cannot even connect to it. The GLiNet app doesn’t help either because the device is shown offline in the app. The screen of the device was displaying normally without any error.

After some futile effort (e.g. restart the device, which is pretty much all I can do), I resort to punch the reset hole 20 sec to factory reset. It can then be connected using the factory default setting. And after I spent all the effort to reconfigure the device, this morning the whole thing repeats. And now I cannot connect to the device anymore.

Is this a normal behaviour? How can I at least get back the hotspot without resetting so that I connect to it to find further information for troubleshooting?

UPDATE: I managed to try to punch the reset hole for 3 seconds which triggered a “network reset” and get connected again. So what was happening behind, and do I need to frequently repeat this step to get the device to normal function?

You can try using a fixed channel.
Also, check if the power drains out.

For the wireless part, I only enabled 2.4G (5G disabled), and the channel is fixed (9, which is the default, if it matters), TX power changed to high. No guest network.

And the battery seems normal. I have only used it for a few days, so I cannot say whether it drains faster or slower than usual.

Can other terminals search for Mudi’s wifi?
Can I see the log?

I tried to search for the Mudi’s signal with two devices. Both unable to search it. Would you share how to extract the log?

Why do you turn off 5G?
Do you use repeater?

When using as repeater, the router need to connect to current network and broadcast its wifi. This may affect the wifi perfomance. So you should always use both 2.4G and 5G to boradcast wifi.

Do not use channel 9, always use 1, 6, 11. When using channels other than 1, 6 and 11 the wifi is prone to interference.

I turn off 5G to save battery. I reduced the TX power to high for the same reason as well. But do you mean if I turn off 5G for downstream connection with my devices will also affect performance of wifi signal to the upstream network?

Channel 9 is somehow the default of my mudi, which I have never modified. I have now changed to 6 for testing. But if channel 9 is not a preferred one, maybe you should consider changing the default setting in future updates.

If you use repeater, the channel will change to the same as your parent wifi. Maybe this is how ch9 is set.
The router will never use ch9 as default.

Thank you. I learnt something new today. But if next time I use repeater will the channel change back to 9?