Mudi GL-E750 Repeater stopped working

My E750 was working fine until last week when the repeater stopped detecting the WiFi network, and I could not connect to the WiFi network I had already memorized.
I did the Uboot restore (4.3.12) and started setting it up from the scratches. The repeater worked as usual. When I installed the following packages: "gl-sdk4-ui-nasview; shadow-useradd; samba4-server; samba4-utils; kmod-usb-storage-uas" to enable network storage, the repeater stopped working.
Any help?

For me, that sounds like you are running out of memory.
Could you please SSH into your device and execute:

df -h
free

There is a result:
/root$ df -h
Filesystem Size Used Available Use% Mounted on
/dev/root 15.3M 15.3M 0 100% /rom
tmpfs 59.2M 2.7M 56.5M 5% /tmp
/dev/ubi0_1 96.1M 13.3M 78.1M 15% /overlay
overlayfs:/overlay 96.1M 13.3M 78.1M 15% /
tmpfs 512.0K 0 512.0K 0% /dev
/dev/sda1 476.7G 154.8G 321.8G 32% /tmp/mount

Please run free as well.

/root$ free
total used free shared buff/cache available
Mem: 121188 48664 13776 2788 58748 49328
Swap: 0 0 0

Any other suggestion as to why the repeater doesn't work anymore?

There is a high probability that it is caused by insufficient memory
It is not recommended to install the nas directly on the device
You can try exroot

1 Like

I didn't do anything to increase the memory usage if that is a culprit for the repeater's stop working. It has worked for more than a year without any issues. I travel a lot and use the repeater and NAS together on a daily basis. I was just wondering why it is not working anymore. The device's memory size has not changed since the last update. Anyway, thanks for the response.

Was it running 3.x before, maybe?

Yes in 3x NAS was installed by default and repeater worked

Yep, but this was version 3.x

Version 4.x has higher memory consumption.

My recommendation if you want to use the NAS features: Go back to 3.x

doing step backward, gaining more features forward, :rofl:

Alternative way is to execute extroot - but this requires more knowledge.
So going back to 3.x is fine.

Try this:

Don’t forget to buy SD card :slight_smile: