Multi-WAN on Flint priority not working

I have Multi-WAN enabled, with the Repeater interface the highest priority followed by the Ethernet interface. Yet the Ethernet interface is always used for all connections. The repeater is connected to a cellular modem and is very fast throughput. The ethernet is connected to a much slower MikroTik router connected to a distant WIFI. I’m checking which connection is being used with and running speed tests. The only way I can get the Repeater interface to be used is by disconnecting the ethernet cable. I’m on the latest firmware, 4.1.0. The Multi-WAN is set to Failover mode. I’ve rebooted multiple times. I disabled the VPN client.

Does repeater show as connected to the Internet?
If you are testing for fault specialisation, please turn on the Forced Refresh Streams option. If you have a browser for testing, use InPrivate mode.

Thanks for your suggestions. Yes, the repeater (and ethernet) show connected to the internet. And if I pull the plug on the ethernet traffic goes through the repeater (so it really is connected). I did try the Forced Refresh Streams with no obvious impact. I would start a new browser and test… still using the ethernet (when both the repeater and ethernet show connected). I tried Firefox private window and it still used the ethernet even though the repeater is the highest priority. So still no luck.

It’s possible that repeater via a cellular modem network block ping used by mwan3 detection.
Please try change IPv4 Track IP like the following picture

This could be confirmed by a ping command:

ping -I wlan-sta0

change to a IP address that’s allowed ping by cellular network.

Good suggestions… still not working. The interface status configuration was already the default (as shown); the pings get through; and the status “lights” on the page show blue. I’ve attached screen shots & ping trace. Bummer. Apparently new users can only attach one media item so I’ve only attached the ping trace.

Could you run the command for debug:

mwan3 status
cp /etc/config/mwan3 /www/

and download the /etc/config/mwan3 files, by access http://
then compress and upload to the forum.

Hopefully this is what you need. Thanks for your assistance. (28.5 KB)

I have the same issue with MT3000
looks like issue is in the software, not hardware

If I have cellular and repeater both on,
When cellular has higher priority, no internet
When repeater has higher priority, everything works
When I manually kill the internet of the repeater, failover does not work, no internet

I’m on 4.2.1 and tried factory reset multiple times, no fixed

Sorry to hear about the MT3000. The Multi-WAN on my Flint is still not working…