Multiple SSIDs on GL-BE3600 (Slate 7)

Hello everybody,

i have received the new GL-BE3600 (Slate 7) and tried to setup multiple SSIDs for different use cases:

  1. Main Wifi (2g, 5g, Wifi 7)
  2. Guest Wifi (2g, 5g, Wifi 7)
  3. IoT Wifi (2g, 5g)
  4. Wifi for Sonos Speakers (2g, 5g)

I have edited the wireless config file (root -> etc. -> config -> wireless) to the following

config wifi-device 'wifi0'
option type 'qcawificfg80211'
option channel 'auto'
option macaddr '94:83:c4:aa:a0:98'
option hwmode '11beg'
option disabled '0'
option country 'DE'
option txpower '30'
option random_bssid '1'
option band '2g'
option htmode 'HT40'
option legacy_rates '1'

config wifi-iface 'wifi2g'
option device 'wifi0'
option network 'lan'
option mode 'ap'
option ssid 'Main Wifi'
option encryption 'psk2+ccmp'
option macaddr 'F6:1B:CC:04:72:9D'
option factory_macaddr '94:83:c4:aa:a0:98'
option key 'Main Password'
option wds '1'
option isolate '0'
option hidden '0'
option ifname 'wlan0'
option ieee80211k '1'
option bss_transition '1'
option sae '0'

config wifi-device 'wifi1'
option type 'qcawificfg80211'
option channel 'auto'
option macaddr '94:83:c4:aa:a0:99'
option hwmode '11bea'
option disabled '0'
option country 'DE'
option txpower '30'
option random_bssid '1'
option band '5g'
option htmode 'HT80'
option channels '36,40,44,48'
option legacy_rates '0'

config wifi-iface 'wifi5g'
option device 'wifi1'
option network 'lan'
option mode 'ap'
option ssid 'Main Wifi'
option encryption 'psk2+ccmp'
option macaddr '1E:83:37:87:72:E6'
option factory_macaddr '94:83:c4:aa:a0:99'
option key 'Main Password'
option wds '1'
option isolate '0'
option hidden '0'
option ifname 'wlan1'
option ieee80211k '1'
option bss_transition '1'
option sae '0'

config wifi-iface 'guest2g'
option device 'wifi0'
option network 'guest'
option mode 'ap'
option ifname 'wlan01'
option encryption 'psk2+ccmp'
option key 'Guest Password'
option ssid 'Guest Wifi'
option macaddr '36:CF:5D:2F:3A:16'
option factory_macaddr '96:83:c4:aa:a0:98'
option guest '1'
option disabled '1'
option wds '1'
option isolate '1'
option hidden '0'
option sae '0'

config wifi-iface 'guest2g2'
option device 'wifi0'
option network 'SIoT'
option mode 'ap'
option ifname 'wlan02'
option encryption 'psk2+ccmp'
option key 'IOT Password
option ssid 'IOT Wifi'
option macaddr '36:CF:5D:2F:3A:16'
option factory_macaddr '96:83:c4:aa:a0:98'
option guest '1'
option disabled '1'
option wds '1'
option isolate '0'
option hidden '0'
option sae '0'

config wifi-iface 'Musik2g'
option device 'wifi0'
option network 'lan'
option mode 'ap'
option ifname 'wlan03'
option encryption 'psk2+ccmp'
option key 'Musik Password'
option ssid 'Musik'
option macaddr '36:CF:5D:2F:3A:16'
option factory_macaddr '96:83:c4:aa:a0:98'
option guest '1'
option disabled '1'
option wds '1'
option isolate '0'
option hidden '0'
option sae '0'

config wifi-iface 'wlanmld2g'
option device 'wifi0'
option network 'lan'
option mode 'ap'
option macaddr '4A:12:9D:9B:91:C5'
option factory_macaddr '94:83:c4:aa:a0:9a'
option ssid 'Main Wifi'
option encryption 'ccmp'
option sae '1'
option key 'Main Password'
option wds '1'
option isolate '0'
option hidden '0'
option ifname 'wlan02'
option ieee80211k '1'
option bss_transition '1'
option disabled '1'
option mld 'mld0'

config wifi-iface 'wlanmldguest2g'
option device 'wifi0'
option network 'guest'
option mode 'ap'
option ifname 'wlan03'
option encryption 'ccmp'
option sae '1'
option key 'Guest Password'
option ssid 'Guest Wifi'
option macaddr '4A:79:88:9E:6C:B9'
option factory_macaddr '96:83:c4:aa:a0:9a'
option guest '1'
option disabled '1'
option wds '1'
option isolate '1'
option hidden '0'
option mld 'mld1'

config wifi-iface 'guest5g'
option device 'wifi1'
option network 'guest'
option mode 'ap'
option ifname 'wlan11'
option encryption 'psk2+ccmp'
option key 'Guest Password'
option ssid 'Guest Wifi'
option macaddr '02:14:8E:CC:09:E8'
option factory_macaddr '96:83:c4:aa:a0:99'
option guest '1'
option disabled '1'
option wds '1'
option isolate '1'
option hidden '0'
option sae '0'

config wifi-iface 'guest5g2'
option device 'wifi1'
option network 'SIoT'
option mode 'ap'
option ifname 'wlan12'
option encryption 'psk2+ccmp'
option key 'IOT Password'
option ssid 'IOT Wifi'
option macaddr '02:14:8E:CC:09:E8'
option factory_macaddr '96:83:c4:aa:a0:99'
option guest '1'
option disabled '1'
option wds '1'
option isolate '0'
option hidden '0'
option sae '0'

config wifi-iface 'Music5g'
option device 'wifi1'
option network 'Music Wifi'
option mode 'ap'
option ifname 'wlan12'
option encryption 'psk2+ccmp'
option key 'Music Password'
option ssid 'Sonos'
option macaddr '02:14:8E:CC:09:E8'
option factory_macaddr '96:83:c4:aa:a0:99'
option guest '1'
option disabled '1'
option wds '1'
option isolate '0'
option hidden '0'
option sae '0'

config wifi-iface 'wlanmld5g'
option device 'wifi1'
option network 'lan'
option mode 'ap'
option macaddr 'B6:83:AA:DC:12:C1'
option factory_macaddr '94:83:c4:aa:a0:9b'
option ssid 'Main Wifi'
option encryption 'ccmp'
option sae '1'
option key 'Main Password'
option wds '1'
option isolate '0'
option hidden '0'
option ifname 'wlan12'
option ieee80211k '1'
option bss_transition '1'
option disabled '1'
option mld 'mld0'

config wifi-iface 'wlanmldguest5g'
option device 'wifi1'
option network 'guest'
option mode 'ap'
option ifname 'wlan13'
option encryption 'ccmp'
option sae '1'
option key 'Guest Password'
option ssid 'Guest Wifi'
option macaddr '62:FB:4F:76:69:16'
option factory_macaddr '96:83:c4:aa:a0:9b'
option guest '1'
option disabled '1'
option wds '1'
option isolate '1'
option hidden '0'
option mld 'mld1'

config wifi-iface 'sta'
option mode 'sta'
option ifname 'sta1'
option device 'wifi1'
option network 'wwan'
option ssid 'Repeater Wifi'
option bssid 'd0:21:f9:89:f3:83'
option macaddr '4A:39:CF:0F:65:0F'
option key 'Repeater Password'
option encryption 'psk2'

I have also setup the network for IOT devices in Lucy, including the corresponding firewall rules. The music wifi connects to the main network

After setting up above mentioned configuration, the additional SSIDs are shown in the GL inet GUI. If all the SSIDs are up, I can see the Guest Wifi, as well as the IOT wifi. The Music-Wifi is not shown on Client devices.

Additionally I can connect only to the Main Wifi and the Guest Wifi, but not to IoT Wifi or Music Wifi (which is, as mentioned, not shown).

With my old Beryl AX (Gl MT-3000) a similar configuration would work properly.

Can somebody help me with the configuration of Slate 7?

Thanks in advance!

I have checked the configuration again and tested further.

I think, that the router recognizes all SSIDs as the same Wifi, therefore i can only enable 1 SSID, as the first SSID overrides the second and third (Guest overrides IOT and Music SSID, IOT overrides IOT), so that only the first SSID is shown.

The Guest and Music SSIDs work on their own. With the SIOT Network there seems to be a configuration issue as a connection is not possible.

Hello,

Please try to execute these commands on the SSH to add WiFi radios (IoT+Custom) which they are on "iot" interface and zone:

uci add network device # =cfg150f15
uci set network.@device[-1].type='bridge'
uci set network.@device[-1].name='br-iot'
uci set network.iot=interface
uci set network.iot.proto='static'
uci set network.iot.device='br-iot'
uci set network.iot.ipaddr='192.168.11.1'
uci set network.iot.netmask='255.255.255.0'


uci set dhcp.iot=dhcp
uci set dhcp.iot.interface='iot'
uci set dhcp.iot.start='100'
uci set dhcp.iot.limit='150'
uci set dhcp.iot.leasetime='12h'


uci add firewall zone # =cfg17dc81
uci set firewall.@zone[-1].name='iot'
uci set firewall.@zone[-1].input='REJECT'
uci set firewall.@zone[-1].output='ACCEPT'
uci set firewall.@zone[-1].forward='REJECT'
uci add_list firewall.@zone[-1].network='iot'
uci add firewall forwarding # =cfg18ad58
uci set firewall.@forwarding[-1].src='iot'
uci set firewall.@forwarding[-1].dest='wan'
uci add firewall rule # =cfg1792bd
uci set firewall.@rule[-1].name='Allow-DHCP'
uci add_list firewall.@rule[-1].proto='udp'
uci set firewall.@rule[-1].src='iot'
uci set firewall.@rule[-1].dest_port='67-68'
uci set firewall.@rule[-1].target='ACCEPT'
uci add firewall rule # =cfg1892bd
uci set firewall.@rule[-1].name='Allow-DNS'
uci set firewall.@rule[-1].src='iot'
uci set firewall.@rule[-1].dest_port='53'
uci set firewall.@rule[-1].target='ACCEPT'





uci set wireless.wifi5g1=wifi-iface
uci set wireless.wifi5g1.device='wifi1'
uci set wireless.wifi5g1.network='iot'
uci set wireless.wifi5g1.mode='ap'
uci set wireless.wifi5g1.ssid='GL Router-IoT-5G'
uci set wireless.wifi5g1.encryption='psk2+ccmp'
uci set wireless.wifi5g1.key='goodlife'
uci set wireless.wifi5g1.wds='1'
uci set wireless.wifi5g1.isolate='0'
uci set wireless.wifi5g1.hidden='0'
uci set wireless.wifi5g1.ifname='wlan14'
uci set wireless.wifi5g1.ieee80211k='1'
uci set wireless.wifi5g1.bss_transition='1'
uci set wireless.wifi5g1.sae='0'
uci set wireless.wifi5g1.disabled='0'


uci set wireless.wifi5g2=wifi-iface
uci set wireless.wifi5g2.device='wifi1'
uci set wireless.wifi5g2.network='iot'
uci set wireless.wifi5g2.mode='ap'
uci set wireless.wifi5g2.ssid='GL Router-Custom-5G'
uci set wireless.wifi5g2.encryption='psk2+ccmp'
uci set wireless.wifi5g2.key='goodlife'
uci set wireless.wifi5g2.wds='1'
uci set wireless.wifi5g2.isolate='0'
uci set wireless.wifi5g2.hidden='0'
uci set wireless.wifi5g2.ifname='wlan15'
uci set wireless.wifi5g2.ieee80211k='1'
uci set wireless.wifi5g2.bss_transition='1'
uci set wireless.wifi5g2.sae='0'
uci set wireless.wifi5g2.disabled='0'



uci set wireless.wifi2g1=wifi-iface
uci set wireless.wifi2g1.device='wifi0'
uci set wireless.wifi2g1.network='iot'
uci set wireless.wifi2g1.mode='ap'
uci set wireless.wifi2g1.ssid='GL Router-IoT-2.4G'
uci set wireless.wifi2g1.encryption='psk2+ccmp'
uci set wireless.wifi2g1.key='goodlife'
uci set wireless.wifi2g1.wds='1'
uci set wireless.wifi2g1.isolate='0'
uci set wireless.wifi2g1.hidden='0'
uci set wireless.wifi2g1.ifname='wlan04'
uci set wireless.wifi2g1.ieee80211k='1'
uci set wireless.wifi2g1.bss_transition='1'
uci set wireless.wifi2g1.sae='0'
uci set wireless.wifi2g1.disabled='0'


uci set wireless.wifi2g2=wifi-iface
uci set wireless.wifi2g2.device='wifi0'
uci set wireless.wifi2g2.network='iot'
uci set wireless.wifi2g2.mode='ap'
uci set wireless.wifi2g2.ssid='GL Router-Custom-2.4G'
uci set wireless.wifi2g2.encryption='psk2+ccmp'
uci set wireless.wifi2g2.key='goodlife'
uci set wireless.wifi2g2.wds='1'
uci set wireless.wifi2g2.isolate='0'
uci set wireless.wifi2g2.hidden='0'
uci set wireless.wifi2g2.ifname='wlan05'
uci set wireless.wifi2g2.ieee80211k='1'
uci set wireless.wifi2g2.bss_transition='1'
uci set wireless.wifi2g2.sae='0'
uci set wireless.wifi2g2.disabled='0'

and

uci commit

reboot