Multiwan settings per device

Hello,

I am using a Flint2 router with the default GL.iNet firmware.

I am wondering if it's possible to setup rules for multiwan per deivce. I am using two differnt internet connections. I have set my Multi-Wan settings to failover and my Ethernet 2 as first priority and Ethernet 1 as second. This works great on my devices but I would like to assing my Homeserver to Ethernet 1 specifc.

I already tried installing the luci-mwan3 package as this seems to have more options but it seems like the original GL.iNet provided Multi-Wan does not really play well with the LuCi package.

I don't really see where to start at to be honest. Does this even work with the default mwan3 package provided?

Chris

I think I figured it out and was able to setup the mwan3 interfaces as I would like. But in the process I somehow "destroyed" my IPv6 connectivity and I don't get why.

This is how my /etc/config/network looks like:

Summary

root@GL-MT6000:~# cat /etc/config/network

config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fdfb:c064:55eb::/48'

config device
option name 'br-lan'
option type 'bridge'
option macaddr '94:83:c4:a4:2e:45'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'

config device
option macaddr '94:83:c4:a4:2e:44'
option name 'lan1.7'

config device
option name 'lan2'
option macaddr '94:83:c4:a4:2e:45'

config device
option name 'lan3'
option macaddr '94:83:c4:a4:2e:45'

config device
option name 'lan4'
option macaddr '94:83:c4:a4:2e:45'

config device
option name 'lan5'
option macaddr '94:83:c4:a4:2e:45'

config interface 'lan'
option device 'br-lan'
option proto 'static'
option netmask '255.255.255.0'
option isolate '0'
option ip6hint '0000'
option ip6ifaceid '::1'
option ipaddr '192.168.55.1'
option ip6assign '60'
list ip6class 'secondwan6'
list ip6class 'wan6'
list ip6class 'wwan6'
list ip6class 'tethering6'
list ip6class 'modem_2_1_6'
list ip6class 'modem_1_2_6'

config device
option name 'eth1'
option macaddr '94:83:c4:a4:2e:43'

config interface 'wan'
option device 'eth1'
option proto 'dhcp'
option force_link '0'
option classlessroute '0'
option ipv6 '1'
option vlanid '0'
option peerdns '1'
option metric '2'

config interface 'wan6'
option proto 'dhcpv6'
option device '@wan'
option disabled '0'
option reqprefix 'auto'
option reqaddress 'try'
option metric '2'
option sourcefilter '1'

config interface 'tethering6'
option device '@tethering'
option proto 'dhcpv6'
option disabled '0'

config interface 'wwan6'
option device '@wwan'
option proto 'dhcpv6'
option disabled '0'

config interface 'guest'
option force_link '1'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option multicast_querier '1'
option igmp_snooping '0'
option isolate '0'
option bridge_empty '1'
option ip6prefix 'fdfb:c064:55eb::/48'
option ip6assign '64'
option ip6hint '0001'
option ip6ifaceid '::1'
option ip6class 'guest'
option ipaddr '192.168.54.1'
option disabled '1'

config interface 'wwan'
option proto 'dhcp'
option classlessroute '0'
option metric '3'

config interface 'secondwan'
option force_link '0'
option classlessroute '0'
option ipv6 '1'
option device 'lan1.7'
option proto 'pppoe'
option password 'private'
option vlanid '7'
option disabled '0'
option peerdns '1'
option username 'private@t-online.de'
option metric '1'

config interface 'secondwan6'
option proto 'dhcpv6'
option device '@secondwan'
option disabled '0'
option metric '1'
option sourcefilter '1'

config interface 'modem_1_1_2_6'
option proto 'dhcpv6'
option device '@modem_1_1_2'
option disabled '0'

config rule 'policy_direct_rt'
option lookup 'main'
option suppress_prefixlength '0'
option priority '1100'

config rule 'policy_default_rt_vpn'
option mark '0x8000/0xc000'
option lookup '8000'
option priority '1101'
option invert '1'

config rule6 'policy_direct_rt6'
option lookup 'main'
option suppress_prefixlength '0'
option priority '1100'

config rule6 'policy_default_rt_vpn6'
option mark '0x8000/0xc000'
option lookup '8000'
option priority '1101'
option invert '1'

config rule 'policy_default_rt_vpn_ts'
option lookup 'main'
option priority '1099'
option mark '0x80000/0xc0000'
option invert '0'

config interface 'modem1'
option device 'eth1'
option proto 'static'
option ipaddr '192.168.100.2'
option netmask '255.255.255.0'

config interface 'wgclient'
option proto 'wgclient'
option config 'peer_2009'
option disabled '1'

config interface 'modem2'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '169.254.2.6'
option device 'lan5'

Everything looks fine so far and IPv4 is working. But I cannot reach any IPv6 destination from any device apart from the router itself. So this might be a firewall issue? As soon as I disable and enable IPv6 via the Gl-Inet interface IPv6 will work for a few seconds.

In LuCi I always see the error " WARNING: Interface wan6 has no default route in the main routing table" and " WARNING: Interface secondwan6 has no default route in the main routing table" in the mwan3 app.

Checking the my routing table:

root@GL-MT6000:~# ip route show table all | grep "default"
default via Ethernet2-IPv4 dev pppoe-secondwan table 7 metric 1
default via Ethernet2-IPv4 dev pppoe-secondwan proto static metric 1
default via Ethernet1-IPv4 dev eth1 proto static src snip metric 2
default via fe80::f27c:c701:2cb0:bfb4 dev eth1 table 4 metric 4 pref medium
default via fe80::f6b5:2fff:fefd:bb3f dev pppoe-secondwan table 8 metric 2 pref medium
default from [...]::/56 via fe80::f6b5:2fff:fefd:bb3f dev pppoe-secondwan proto static metric 512 pref medium
default from [...]::/64 via fe80::f6b5:2fff:fefd:bb3f dev pppoe-secondwan proto static metric 512 pref medium
default from [...]::2a30 via fe80::f27c:c701:2cb0:bfb4 dev eth1 proto static metric 512 pref medium
default from [...]:2600::/59 via fe80::f27c:c701:2cb0:bfb4 dev eth1 proto static metric 512 pref medium
default via fe80::f6b5:2fff:fefd:bb3f dev pppoe-secondwan proto ra metric 1024 expires 1570sec hoplimit 64 pref medium
default via fe80::f27c:c701:2cb0:bfb4 dev eth1 proto ra metric 1024 expires 118sec hoplimit 64 pref medium

Probably there is plugins conflict in gl-kmwan and mwan3.

If you require to use the mwan3 to manage the Multi-WAN, perhaps recommend installing the vanilla OpenWRT firmware.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.