MV1000 WireGuard IPv6 traffic routing


Does the MV1000 support IPv6 with a a WireGuard VPN provider? Also if the MV1000 connects to the VPN provider with IPv6, does it support routing of IPv6 traffic from clients (like an Apple TV) through the VPN?


It should. Maybe you can just try

I do not have the MV1000 so I am asking before I make the purchase

Just to close the loop on this, I received my MV1000 and tested this. WireGuard IPv6 works and all clients connected to the MV1000 WiFi can use the VPNs IPv6 address. So all is good here.

The one issue I am seeing is that every time I reboot the MV1000 WireGuard stops working and also IPv6 stops working. Reconnecting the VPN does not solve the issue. To get it up and running again I would have to remove the WireGuard profile and add it back again. Is this a known issue?

1 Like

This should not be the case. I will ask engineers to check

I have took a test, WireGuard and IPv6 is ok.

Pelease help to confirm some issue:
Does the WAN have access to IPv6 when MV1000 reboot?

What I found is that just after reboot, as long as I remove the WireGuard profile and add it back in, VPN IPv6 works even without an IPv6 WAN IP. Also my MV1000 is connected to main Asus router so the current WAN IP is just a local address that starts with FD.

I’m sorry that I have a confused.we confirm some issue:

1>VPN and Wireguard are two different applications.
2>VPN IPv6 could work without an IPv6 WAN IP.
3>WireGuard IPv6 could not work with an IPv6 WAN IP.
4>After reboot,WireGuard IPv6 could not work and WireGuard IPv4 could work without an IPv6 WAN IP.
5>After reboot,then remove the WireGuard profile and add it back in,WireGuard IPv6 and IPv4 could work.

Whether the above mentioned is the problem you are facing now?

Remove #3. That is not what I am experiencing.

Correction to #4- both IPv4 and IPv6 do not work after reboot.

The rest of your items are correct.

Hi xyber,
I’m so sorry to have caused you trouble.I have verified a lot of tests and ‘the WAN port probability fails to obtain ipv6 after reboot,then WireGuard will not work propertly’.Thank you very much for your feedback.

Currently, we are actively optimizing ipv6 capabilities.This may take some time.

1 Like

Hi Lizh,

I am actually no longer experiencing this issue. WG reconnects automatically now after I do a reboot. The WG connection also obtains both IPv4/6 addresses from my VPN provider and clients that tunnel through that also use the same IPv4/6 addresses.

However, please check my other post here. There is an IPV6 leak when using WG and when the MV1000 has both IPv4/6 WAN IPs from my ISP.


Noticed and recorded in bug list.

1 Like

How are you guys seeing IPv6 in Wireguard ? I just got my MV1000 and was about to ask support whats up with this when I found this thread.

I have the MV1000W with firmware 3.105.

I imported a wireguard client.conf that has two IP addresses, IPv4 and IPv6. Using them on Android, Linux or Windows the client will get the two addresses and route IPv6 over WG even if WAN has only IPv4.

On the MV1000W under VPN → WG → Interface → IP Address it has ignored all IPv6. If I add it manually, it fails “Invalid IP”.

I CAN set AllowedIPs to, ::/0 but if I put any IPv6 address into my interface address field, it will not accept it. I tried comma seperated and space separated addresses. Also tried IPv6 address only.

You would need to install firmware 3.203 for IPv6 to work with WG

Is that released already or do I need the beta4 from

Yes you need beta 4. You have the correct link

Cool I installed 3.203 beta4 and it does let me import a wg profile that is dual-stack but when I ssh into the device and check wg0 interface it only has IPv4 address. And I see npwhere to assign IPv6 ULA to the LAN. Do I need to toggle the global IPv6 switch on to make things work ? The IPv6 switch is off by default but it seems to talk only about IPv6 on WAN ? I want to have IPv4 WAN (hotel wifi) and have my LAN clients get IPv6 ULA or a /64 that comes in over the wg client.

Edit: This here gives an auto generated LAN ULA.

But when I check ifconfig wg0 in SSH, the WG interface shows no IPv6 address which is weird because the profile and WG client settings in the UI clearly show there is a /128

Mine has an IPv6 address in ifconfig. Do you have an IPv6 address in the IP address fields of your WG setup?

Yes. The profile will be dual stack when I paste it into wireguard android or windows client.

It has a single public IPv4 /32 and IPv6 /128

So when you go on on a client you don’t see the VPN’s IP address either? Does your ISP provide you with an IPv6 address?