My dns is leaking

I’m using two beryl AX. One as the serve,r and one as the client.
I have Port forwarded from my isp router to the server with the defult port. And connected with wireguard succesfully. I didn’t enable ddns as it wasn’t letting me, but that shouldn’t be a problem as i have a static ipv4 address from my isp. When I test the ip address when im connected to the client, everythings good and it is showing the correct ip (the one which my server is connected to through ethernet) But when i check for leaks its shows leaks of the ip that the client is connected to via wifi. The wifi my client is connected to is a diffrent isp in the same property.
What could be the problem?

I don’t want to speculate yet. Does the DNS leak when using a wired connection to the Beryl AX WG Client? Please use the following:

Yes, Ive just tried it and It shows that it still leaking. A few hits but yes
Anything i can do to try fix it?
Thanks for the help

The simplest way I can think of is to set the Beryl AX WG Client to use Encrypted DNS via DOH & enable rebinding & override. That will force all lookups through HTTPS which is handled by the WireGuard tunnel if you have the VPN Client set to Block Non-VPN Traffic & Global Proxy enabled.

  • GL GUI → Network → DNS
  • GL GUI → VPN Dashboard → Global Options & Global Proxy
1 Like

so do this?

Should this be the setup?

Close. NextDNS is a subscription based service. Change out the Encryption Type to ‘DNS over HTTPS’ & select a preferred server. Cloudflare is quite reliable if you don’t have an issue using USA-based service providers.

IP Leak should state CLOUDFLARENET.

1 Like

You could check this website Anonymity check how is safe for you.

Thanks man! Thanks for you help, Just like you said

1 Like

Pass. I’m not going to feed Google.

Good stuff! Have a good one.

Adguard home blocked to Google feed. So don’t worry.

As would my block lists. That doesn’t mean others shouldn’t be aware.