My GL-MT300N-V2 is unusable with release 2.71


#1

Hi, yesterday i received my first GL-MT300N and i explored it (i bought it to connect as a VPN client and redirect all my home traffic on it)
I have tried many times to connect with Nord Vpn, following the link (https://nordvpn.com/it/tutorials/gl-inet/) with no result, using some configurations that i use everyday on my Lubuntu laptop using the nordvpn client built for Linux.
So i tried to seek a new firmaware (my MT300N-V2 arrived with the release 2.61 installed on it) and the firmware program suggested me to install the release 2.71 (the latest stable release).
I did it but my MT300N-V2 has become unusable and now i am able to reach it only with ssh and not in web, so i don’t know how to use it.
I tried to unbrick it following a video on youtube but with no result.
How can i install the old firmware having only a ssh connection with my MT300N-V2 ?
Many thanks


#2

First, you need do some some reading and research, as you don’t really seem to know what you’re doing!

Go to the support section and read the docs for unbricking (not that your router is bricked).

Have you tried a reset (directions in support)?

Try the testing firmware - http://download.gl-inet.com.s3-website.us-east-2.amazonaws.com/firmware/mt300n-v2/testing/


#3

Hi glitch and thanks for the answer.
I am not an expert but i know what i am doing, and normally when inside a program created by the manifacturer i find an option that lets me upgrade a router, i am fine and i feel sure that everything will be ok, so i am very frustrated that now my router is unusable because i did nothing of strange and/or dangerous.
I already found the file that you sent to me, but if you had read better my post, i told that i didn’t find how to install the firmware having only the ssh connection and not the web ui that has broken with the upgrade.


#4

Please use the firmware mentioned by glitch and upgrade using this guide.

https://docs.gl-inet.com/en/3/troubleshooting/debrick/

If you have a problem pls tell the details, better with photo and screenshot.


#5

Or you could try a reset first and see if you can get to the GUI then.


#6

Thanks alzhao, i have been able to reprogram the MT300N-V2.
I have downloaded the release previous to 2.2.271 (the release who bricked my MT300N) exactly i downloaded lede-mt300n-v2-2.27.bin from official gl-inet site (https://dl.gl-inet.com/firmware/mt300n-v2/v1/).
I have followed the guide https://docs.gl-inet.com/en/3/troubleshooting/debrick/ and i have been able to get my MT300N-V2 ready and functioning.
Now i have the same problem that lead me to reprogram the MT300N-V2, namely OpenVpn does not connect to my NordVpn sites.
My laptop connects normally using the Nordvpn client for Linux (i use Lubuntu) but if i try to connect on the same site using the same credentials with OpenVpn in my MT300N it dows not function (see picture)


#7

What happens when click “apply”?


#8

I am not sure what there is no log. Generally it is due to some settings in nord causing openvpn to exit.

Can you use 3.0 firmware for MT300N-V2?
https://dl.gl-inet.com/firmware/mt300n-v2/testing/


#9

Hi alzhao and many thanks for giving me your help.
Now i have been able to make Vpn client functioning (i don’t know how, i believe that before i tried to connect in UDP).
I observe a strange thing, when the Vpn client is connected another device (tun0) becomes active and that is the device of the vpn client but if i execute netstat -r i can see that there are two default gateways, one regarding tun0 and the other regarding my adsl router.
If i go to analize my internet traffic i can see that i am going out with adsl router and not with tun0 as i expected (see pic attached).
Where is the problem ?
I have my device connected with my adsl router with wan (DHCP address 192.168.1.2) and to my home hub with lan (IP address 192.168.8.1), is it correct ?
Many thanks in advance


#10


#11

So it seems the original problem was because you didn’t bother to click “apply”!

The IP’s you give look correct.

Just do an IP check and leak test on something like doileak.com


#12

You can just check your IP address e.g. checkip.org to see if your data is via vpn. If yes then it is OK.


#13

Hi glitch, no the problem was not related to Apply not pressed but, i believe, to my choice of a Vpn endpoint using UDP and not TCP.
I thank you for your answers but you sayd nothing about the strangeness of two default gateways.
For alzhao, yes i checked my ip and in both situations (Vpn connected or VPN disconnected) i go out with the same IP address (the Ip address of my internet supplier).
Could you confirm that my way to connect the device is right ?
Thanks in advance


#14

Then you have problems! If you have the screenshot of your last post (shows you connected to Nord) then the IP’s should be different.

Also, UDP works fine with Nord, so that was not your problem.


#15

Can you tick the force vpn option?

Pls also show the Internet status page. I want to check how the router is connect to internet.


#16

I solved everything, thanks to all.
The last problem, the two gateways and the traffic that was not routed over the VPN vas related to a permission of the firewall that denied the forwarding of the traffic between WAN and VPN.
I clicked on the two options boxes and now everything is ok, all my traffic is routed over The VPN.
Many thanks to everybody and a happy new year.


#17

Did you change settings in luci? Those settings will be automatically set up when you connect vpn in the GL UI.

If you set up anything in luci, please state this in the post. Otherwise no way to find out the problem.


#18

Yes Alzhao, as i said in the previous post i have clicked on two options in the firewall section of the interface.
I don’t know if what you call Luci is the section of the device interface where i enter clicking on the button “Advanced settings”, i can say that i entered in that section and i found those options in the firewall section.
In the next days i will receive another device and i will go to replicate the process, so i can confirm the the problem exists or it has been a momentary issue.


#19

Yes, advanced settings = LUCI.

The original “problem” appears to be that you went straight in Luci and fiddled with the firewall settings without undertstanding what you were doing properly.