My router lost the internet connectivity when connected to VPN (GL-MT300N-V2 Mango)


I recently upgraded my firmware to the snapshot(2021-12-25) version to solve some problems with my router.

When using Wi-Fi repeater mode, there was a problem that only worked when the connection was retried more than 10 times, and this was resolved in the snapshot version.

However, if I am connected to VPN, there is a problem that the Internet is not connected. It appears that there is no problem in the administrator UI, but it is not actually connected to the Internet.

Please report this problem to the development. Thank you.

I just tried 3.211 beta4 on Mango, using Nordvpn and it works normal.

What vpn service are you using?

I am using Ivacy VPN. This works well in the ‘stable’ version, but there is a problem in the ‘beta’ and ‘snapshot’ versions.

I am using 3.211 beta4. Just subscribed ivacy vpn. Downloaded ovpn of udp as in the docs here OpenVPN Client - GL.iNet Docs

Configure on the router and just pick up a server and connect. Everything are working.