My Wirdguard Client is stuck on "the client is starting, please wait"

Hi! I am very very much a novice and do not understand the lingo BUT I have 2 GL-MT6000 Routers and I am trying to create a link between the two so that I can travel for work while my IP remains at home.

I set everything up and now my Wireguard Client is stuck on “the client is starting, please wait” and I have no idea what I am doing wrong and cannot find the answer elsewhere. If anyone can help me, I would really appreciate it!

This is the current log:

Sun Feb 25 15:32:38 2024 kern.info kernel: [ 2396.929579] wireguard: wireguard-hotplug IFNAME=wgclient ACTION=REKEY-TIMEOUT
Sun Feb 25 15:32:43 2024 kern.info kernel: [ 2402.043824] wireguard: wireguard-hotplug IFNAME=wgclient ACTION=REKEY-GIVEUP
Sun Feb 25 15:32:43 2024 user.notice wireguard-debug: USER=root ifname=wgclient ACTION=REKEY-GIVEUP SHLVL=1 HOME=/ HOTPLUG_TYPE=wireguard LOGNAME=root DEVICENAME= TERM=linux SUBSYSTEM=wireguard PATH=/usr/sbin:/usr/bin:/sbin:/bin PWD=/
Sun Feb 25 15:32:46 2024 daemon.notice netifd: Interface ‘wgclient’ is now down
Sun Feb 25 15:32:46 2024 daemon.notice netifd: Interface ‘wgclient’ is setting up now
Sun Feb 25 15:32:46 2024 user.notice firewall: Reloading firewall due to ifdown of wgclient ()
Sun Feb 25 15:33:09 2024 kern.info kernel: [ 2427.616944] wireguard: wireguard-hotplug IFNAME=wgclient ACTION=REKEY-TIMEOUT
Sun Feb 25 15:33:31 2024 kern.info kernel: [ 2449.993356] wireguard: wireguard-hotplug IFNAME=wgclient ACTION=REKEY-TIMEOUT
Sun Feb 25 15:33:54 2024 kern.info kernel: [ 2473.008298] wireguard: wireguard-hotplug IFNAME=wgclient ACTION=REKEY-TIMEOUT
Sun Feb 25 15:34:16 2024 kern.info kernel: [ 2495.384794] wireguard: wireguard-hotplug IFNAME=wgclient ACTION=REKEY-TIMEOUT
Sun Feb 25 15:34:37 2024 kern.info kernel: [ 2515.843442] wireguard: wireguard-hotplug IFNAME=wgclient ACTION=REKEY-GIVEUP
Sun Feb 25 15:34:37 2024 user.notice wireguard-debug: USER=root ifname=wgclient ACTION=REKEY-GIVEUP SHLVL=1 HOME=/ HOTPLUG_TYPE=wireguard LOGNAME=root DEVICENAME= TERM=linux SUBSYSTEM=wireguard PATH=/usr/sbin:/usr/bin:/sbin:/bin PWD=/
Sun Feb 25 15:34:40 2024 daemon.notice netifd: Interface ‘wgclient’ is now down
Sun Feb 25 15:34:40 2024 daemon.notice netifd: Interface ‘wgclient’ is setting up now
Sun Feb 25 15:34:40 2024 user.notice firewall: Reloading firewall due to ifdown of wgclient ()
Sun Feb 25 15:34:46 2024 kern.info kernel: [ 2524.793912] wireguard: wireguard-hotplug IFNAME=wgclient ACTION=REKEY-TIMEOUT
Sun Feb 25 15:35:08 2024 kern.info kernel: [ 2546.530699] wireguard: wireguard-hotplug IFNAME=wgclient ACTION=REKEY-TIMEOUT
Sun Feb 25 15:35:29 2024 kern.info kernel: [ 2568.277080] wireguard: wireguard-hotplug IFNAME=wgclient ACTION=REKEY-TIMEOUT
Sun Feb 25 15:35:52 2024 kern.info kernel: [ 2590.643417] wireguard: wireguard-hotplug IFNAME=wgclient ACTION=REKEY-TIMEOUT
Sun Feb 25 15:36:14 2024 kern.info kernel: [ 2612.380132] wireguard: wireguard-hotplug IFNAME=wgclient ACTION=REKEY-TIMEOUT

Hey :wave:

it’s not that easy, because you need to make sure that a few prerequisites are met.

  1. One of the Flint2 have to act like a server. This one needs to be reachable from the internet. If there is a router before the Flint2 you have to set up port forwarding for the WireGuard port (which is UDP/51820)
  2. The Flint2 acting as a server must be connected by “real” internet (no cellular, no Starlink)

Make sure to follow this guide: Build your own WireGuard Home Server with two GL.iNet Routers - GL.iNet Router Docs 4

Are these prerequisites met?

Hi! Thanks so much for the easy to understand response!

The guide you included I have already followed when I initially set it up but I think I may have messed up port forwarding? DoI need to set up port forwarding on both or just in one direction?

You need to set port forwarding at your home (where the Flint2 will act like a server) from your ISPs router (or modem) to your Flint2. Port has to be UDP and 51820. Port forwarding is usually just in one direction: from internet to your device.