Need a hint about getting TinyProxy going

I don’t know specifics of GliNet busybox and OpenWRT implementation, but I logged into shell and ran:
opkg update
opkg install tinyproxy

That worked fine but I can’t edit /etc/config as it’s read-only.

If I attempt:
tinyproxy -d

then I get tinyproxy: Could not open config file “/etc/tinyproxy.conf” but I can’t create an /etc/tinyproxy.conf on the read-only file system.

Is there some documentation to help me get kickstarted? Everybody on forum seems to already know so a noob can’t get much more info.

Which model are you using?

Once it says read-only, the filesystem might be mounted in tmp, or the flash is full.

You can ssh to the router, and execute the command: df -h, show the output here. You also can try to reset to factory settings, it should work.

Yes, it had maxed file system when I was installing other packages. Reverted firmware and reloaded fine. Thanks.
Then, I did:
opkg update
opkg install tinyproxy
vi /etc/tinyproxy.conf
tinyproxy -d
and tested from another computer with:
curl -v --proxy
and got the IP of Mango’s WAN hotspot so it worked fine.

But how can I get the service to startup at boot? I went to luci and selected tinyproxy but luci commands don’t seem to work. What’s the GL.iNet way of setting this up? I noticed tinyproxy was listed in init.d:
root@GL-MT300N-V2:~# ll /etc/init.d/ | grep tinyproxy
-rwxr-xr-x 1 root root 3422 Jul 26 2018 tinyproxy*
but a reboot doesn’t start the service. I’m confused.

Figured it out. Noob here about uci but apparently that was not enabled.
uci show tinyproxy
uci commit tinyproxy

Glad to hear it worked and thanks for let me know.

Maybe you also can execute /etc/init.d/tinyproxy enable to enable boot automatically.

Are you pleased with the performance of tinyproxy? When I use it as a proxy, my laptop goes from 3 seconds to load to 30+ seconds. Complex web sites are epically slow via tinyproxy on my GL-AR750s.