Need help getting SMS to work

can you try to use AT+CGSMS=2 to set the modem to “packet domain preferred”

Here ya go


sounds like a case for @hansome then. :saluting_face:

Try to send the AT commands without GL binary - as I said above I am suspecting it!

picocom -b 115200 /dev/ttyUSB2

1 Like

Sorry I don’t have a USB UART adapter at the moment, will check it out once I get one.

SSH should be enough?

How do I use picocom via SSH? There is no picocom package on this router.

I was able to get it to work! install minicom:

opkg update
opkg install minicom

Check the baud rate:

stty -F /dev/ttyUSB2
speed 9600 baud; line = 0;
min = 1; time = 5;
ignbrk -brkint -icrnl -imaxbel
-opost -onlcr
-isig -icanon -iexten -echo -echoe -echok -echoctl -echoke

Connect to the modem:

minicom -b 9600 -D /dev/ttyUSB2

Enable Local Echo to see entered commands:

CTRL+A then E

AT+CMGF=1 then hit Enter
AT+CMGS=“+phonenumber” then hit Enter
> write your message which does not appear on minicom then hit CTRL+Z

+CMGS: 8

To exit

CTRL+A then Q then Enter

NOTE: the first and second AT commands needs to be entered as fast as possible! Otherwise you will receive the +CMS ERROR: 304

Screenshot PoC:

First time it failed because of the delay in pasting the second command!

Thank you!

I prepared both commands that have to be entered as fast as possible and copy pasted them really fast.
I’m still getting the CMS 304. Manually typing really fast also didn’t work.

Update: Seems like I managed to be fast enough this time, but it’s a Error now.


you may have messed up the modem… try to restart the sms services:

root@GL-X3000:~#  service |  grep sms
/etc/init.d/sms_manager       	   enabled	   running
/etc/init.d/smstools3         	   enabled	   running

root@GL-X3000:~# service sms_manager restart && service smstools3 restart
Creating minimum spool directories

Tried, same error


Paste the first command BUT DO NOT HIT ENTER

Then copy the second command with contains your number

Now Hit Enter and swiftly paste the 2nd one and hit Enter


now its CMS again

Yuo can concatnate two comands and forget about the seift thing! Syntax like this:


then hit Enter :slight_smile:

You need to restart both as I did!

I wasn’t lying about being fast :slight_smile:, now concatenated


Enable echo using the command I showed above and take a screenshot

Should be like this - notice the second command does not start with AT

then write your msg and hit CTRL+Z

Screenshot 2024-04-23 at 23.58.33

minicom messed up my paste by adding dots instead of double quotes…

now it did work. *after typing it manually

To paste in a shell:


Nope, mac won’t let me