Need help getting SMS to work

I am using a T-Mobile Magenta Max SIM. I did receive text messages when I first turned the Puli AX on the first time, and then again when I updated the firmware. Like something in booting up and connecting the first time triggered fetching SMS, but then it stopped working. I can’t send or receive. I am only connecting to 5G bands and I have ipv6 enabled. I’m not sure what is and isn’t relevant… Are there any settings or commands I should look at?

  • Device: Puli AX
  • Firmware version: 4.4.8
  • Modem firmware: RM520NGLAAR03A03M4G_01.200.01.200

4.4.6 Do I have this problem?

Are you asking if I still have a problem with SMS if I downgrade to 4.4.6?

I don’t see a version 4.4.6 on the Puli AX firmware download page. The latest stable version is 4.4.4.

Is you can use 4.4.4 test under?

Ok, ywp, I finally got a chance to downgrade to the 4.4.4 Puli AX firmware. SMS send and receive are still not working.

Based on something I read in another post, I tried band locking to only LTE bands. I can confirm that SMS send and receive do work when I do this. Any ideas of what I could try to get it working via 5G?

Afaik 5G does not support SMS, same like Calls which will downgrade to 4G in most cases.

Thats wrong. If you are talking about 5G itself, it does support SMS! + VoNR for Calls.

Might depend on the provider.

I am using Telekom in Germany and my phone will always disconnect 5G while doing a call - answer from
provider was that 5G calling isn’t supported yet.

Correct! That’s the default behavior for such technology now.


As you can see many users today are complaining about issues when sending/receiving SMS on their devices! Are you using Spitz x3000 (or Puli AX) by any chance ? Can you send and receive SMS from your device?

Default behaviour for carriers, not the technology.

1 Like

Does your ISP have VoNR? If yes, what is your carrier ?

As far as I know it has been under testing for most carriers.

Vodafone Germany activated VoNR last year. Carriers are slowly adapting. I was just talking about purely 5G technology. I personally don’t use VoNR and do not have any devices that support it.

1 Like

I have a XE3000 and sending SMS was fine.

There seems to be an issue with 5G Standalone modem firmware. Non-Standalone SMS is working fine. I think the modem firmware devs did not implement this feature in the firmware.

We might need support from quectel.

It works fine on my Spitz too. Wondering why many related issues have popped up on the forum last two days?!

Or It could be an issue with the Modem_AT script made by GL devs?

I have to admit that I only tried sending SMS by the GL GUI.

Yeah something isn’t right. I tried sending an SMS via AT command, doesn’t even prompt the message.

Maybe this helps? sms - +CMS ERROR: 304, sending message using at command - Stack Overflow

Good eye!
But sadly another Error, this time without a number. :slight_smile: