Need help, routing


#1

Hello!

I do need your help, please.

I have got 192.168.2.0/24 on br-lan and 192.168.178.0/24 on eth0. openvpn tunnel is active. It is the default configuration of the network interfaces and of the firewall.

My pc on 192.168.2.0/24 can reach the internet via vpn. that is fine, but the pc cannot reach the device 192.168.178.2.

the gli-router can connect to 192.168.178.2.

Thanks in advance for help.

Mikee

 


#2

I forgot to give some information about the router.

ar300m with 2.263.


#3

I resolved on my own. I added an second ip address to the client.


#4

Thanks for reporting.


#5

Can you please explain in detail how to do this. I have the same problem i cannot access the pc from the network.

local network 192.168.86.1
glinet 192.168.8.1
glinet pc 192.168.8.219

I would like to connect the network share from my local network. Say 192.168.86.45 ----> 192.168.8.219 share bypass the vpn for local traffic.

Thanks


#6

hi! you need add route to client for this network or add second ip to network client interface.

google now “add second ip” “route add” for windows os.


#7

This won’t work. It needs to be done through then ar750 router.


#8

Have you tried to install on the client second ip 192.168.86.219?

what is your operating system?


#9

Sorry maybe I didn’t explain the gli is running a vpn. The client machine is windows 10. I tried adding the extra ip but I had to make the first ip static and assign dns settings which I assumed are the vpns because of dns leak. So when adding the second ip with .86 I could not see from the .86 network.