Need to debrick ar300m

I was trying to flash openwrt 21 clean firmware on my ar300m but not sure what went wrong, after the update its booting only on NOR firmware.

I tried uboot method but uboot is not allowing me to flash .img files. I get the errors file is either too large or you are trying to update ART which is not allowed (attached). My switch is on left side only (near reset button)

I flashed the latest uboot .bin file which i got from it got flashed. Afterwards I again tried to flash the ubi img files but again same error as attached.

Can anybody guide how can I debrick my router to get back to nand firmware.

You need to update your uboot first hence your issue.

Flash that and then see after that if you can flash your openwrt image.

As the page your on is the uboot upgrade page.

Hi Solidus,

As i mentioned in original post, i have already updated uboot but even after it I can not flash the img file.


Sorry nevermind, seems i was going into wrong page i.e. instead of just which is for firmware updating :see_no_evil:
Using this page i was able to update the firmware without any probs, pretty n00b of me lol :bowing_man:

1 Like