[Need urgent help] My GL-S1300 seems bricked

Hey, I followed this tutorial: Success Path to Imagebuilder OpenWRT for S1300

exactly, but unfortunately after the upgrade then the device isn’t starting anymore, no lights, nothing. I can’t get into uboot (web), tftp recovery might be possible, but I don’t know the IPs (and no one else on search engines to find as it seems), is it possible that if I use the GL-inet image builder in a VM that there’s a possibility to flash it through that again? I have the device a week or so, it’s not my first GL-Inet device therefore I didn’t expect that I could brick it and I don’t think its really bricked, but the standards like 192.168.1.1 or 192.168.8.1 aren’t working. I did nothing else as the guy in the above linked post.

Proof of ownership can be provided to GL-Inet Stuff I have the packaging. Telnet, SSH etc. not working, but I also don’t know any rescue ip other than 192.168.1.1 so I hope anyone can help me out. Thanks.

Did you follow this guide?

https://docs.gl-inet.com/en/3/troubleshooting/debrick/

1 Like

Have you checked the AC Adapter power supply? Just did some test/recoveries on some Amazon AU returns and one of the B1300s worked fine EXCEPT for a dead AC Adapter power supply :slight_smile:

1 Like

Yes, I already did test it with two (ofc also 12V) others, didn’t help unfortunately. I think it’s on when the power is attached, since the network statistics are suggesting that it’s at least not dead. But there ends my knowledge also, I don’t know how to recover it without the uboot-recovery interface or how to use TFTP properly or if that’s even if possible via the wan port. Next problem would be, I have no usb to serial adapter, never used such a thing and wouldn’t know how. Also, yes I did try the debrick tutorial, the problem is I can’t access the uboot-http after flashing the img file s1300-factory-to-openwrt.img, all LEDs are staying off. @limbot @Johnex

Hi, are you trying to flash openwrt compiled by this repo:

Did you check the README.md for flashing guide

1 Like

@hansome Hi, yes, I did. At least to the extend it’s overlapping with the tutorial I posted in the first post. //edit I Just noticed that they are not the same, I followed the wrong one posted in the first post.

  • I wasn’t able to get to the OpenWRT sysupgrade part; the LEDs stopped working at the second flash, aka point 5 on the github tutorial. The first flash was done in the way its described, worked. After that I followed the other tutorial, so I used the factory-to-openwrt-, rebooted into uboot-http without problem, and flashed then flashed the wrong image. The LEDs went down while flashing.

But after the explanation on your Github,

  • “The kernel and rootfs of factory firmware are on eMMC, and OpenWRT firmware is on NOR flash. The transition image includes U-boot and partition table, which decides where to load kernel and rootfs. After you install OpenWrt image, you can switch between factory and OpenWrt firmware by flashing transition image.”

  • This would have just brought me in consequence back to the partition on the eMMC, or not? I’m using GL-Inet routers for quite a while now daily and never managed to soft-brick or brick any of them. At max, a few restarts where necessary or at worst I couldn’t explain myself why it’s working again after a few hours, but bricking it seemed for me as of yet impossible, that’s why (in theory) the only explanation for myself would be the above written, but still, theoretically I would then be just back on the eMMC, which should have the uboot partitions and all that.

  • Now, how mandatory is it to use “192.168.1.0” as IP address in the case we have tracked it down now since I always used 192.168.1.11 or 192.168.1.2 for the computer and 192.168.1.1 for the router/gateway, is it worth a try / safe to try to boot it with these parameters?

  • If it helps/is necessary I can share a Debian VM via any desk or alike, we configure there the image builder, I use my Gigabit switch (if we must do something while booting, this is a great help IMO). You could maybe take over the control and see what you can get?) As said, there are no lights on the router, but the macOS network utilities are showing that there is something. That’s why I’m thinking of telnet or alike for recovery.

  • If you think that has all no point, please tell me asap what I could do else, and if the only thing is opening the unit and connect via an USB to serial adapter, I’ll just order one, just in case… “RS232 3.3V / 5V PL2303 Module Serial TTL USB UART Board”

Nevertheless, I really hope theres any other possibility.
I’d feel a lot safer to not soft- but really brick it this time, if I could use familiar (aka software only) methods.

Thank you very much!

/edit again:
I tested it now again after having it for almost a day turned off and was using the ethernet, not the wan port and saw that the S1300 is definitely reachable. Just not for me or the uboot-web

Really sorry for the inconvinience.

This would have just brought me in consequence back to the partition on the eMMC, or not?

==> Only if you flashed s1300-openwrt-to-factory.img.

Now, how mandatory is it to use “192.168.1.0” as IP address in the case we have tracked it down now since I always used 192.168.1.11 or 192.168.1.2 for the computer and 192.168.1.1 for the router/gateway, is it worth a try / safe to try to boot it with these parameters?

==> set PC ip to 192.168.1.11 or 192.168.1.2 both okay when using uboot web.

There was a old version of buggy uboot that will erase the whole nor flash when flashing openwrt/lede image. And the nor flash has the uboot bootloader while the eMMC has only filesystem, so that bug will cause to truely brick the device.

It seems that you haven’t manged to flash s1300-factory-to-openwrt.img or s1300-openwrt-to-factory.img image, they have the right uboot. If device bricked, no software only solution is available. How can you tell S1300 is reachable, could you show some picture?

1 Like

Answered your mail and for sure I have only s1300-factory-to-openwrt.img these used. That was the problem in the other tutorial apparently, sounded like you should use both and then flash OpenWRT, I test it again to be sure but theres a connection reset after pressing the power button, just only the network logfiles, which doesn’t help much. 100% I’m not yet.

@fellow gl-inet-users just a PSA:
If one of you has the idea to try this also, the “wrong” tutorial by a user I posted above is now flagged correctly as wrong, it’s highly probably correct what @hansome posted and I’m sure if you follow his tutorial exactly it will work. But remember apparently is it relatively easy to brick your device compared to the “undestroyable” travel router ( & all with older chipsets basically) series. The official firmware is for both the B1300 and S1300 to find here just update this, just my advice because it’s apparently IMO not worth it. They get regularly updated, including a clean openwrt release.

If you used s1300-factory-to-openwrt.img before flash OpenWRT, that will be okay. No need to use s1300-openwrt-to-factory.img. So maybe it’s the s1300-factory-to-openwrt.img not suceccesfully flashed.

I’ll send you a 16MB bin file to reprogram the flash.

1 Like

Got it, I’ll update here when my tools have arrived. And yes, it sounds very much like you’re right, for some reason it’s probably not successfully flashed.^^ But I won’t try it again I’m happy when I managed to fix it and stay then rather on stock firmware

Yeah i flagged it as wrong and closed it. Didn’t expect anyone to not read the entire thread and read the posts i made saying it was wrong.

Sorry for that.

1 Like

Update for the support @hansome
My set I send you is arrvived, I’ll get it tomorrow and try to document the recover procees and hope this is at least if I can’t make it maybe in the realm of possibilities I get to send it then back to HK, but with the data I have and the video tutorial etc. I’m optimistic I can solve it and document it for everyone who might for whatever reason wants to do that as well.

Sorry for bumping an old post, but I’m in the same situation.
My device was fully working with a customized-firmware I built from your repo. Two days ago, I performed some modifications (adding new drivers), and after flashing, no lights and no serial access, so It might be a dead EPROM.

I have the tools to reflash it even without desoldering, but I can’t find the file anywhere, only references to it in forum threads.

So, how can I get the magic 16MB bin file to reprogram the flash?

Very many thanks, Manuel

Please send me a picture of your device’s mac address and sn label, to email handongming#gl-inet.com

Email sent, anywsy I have ordered a new s1300.
Can I “copy” flash from one device to another? Or it is linked to serial numer or mac address?

Very manu thanks, manuel

Hello Lolo_Bee, I replied your email yesterday, maybe check your spam.
Yes it is linked to serial numer or mac address. Every devices have it’s own ART partition, copy to another will cause performance loss to some extent.

Hello hansome, email reached SPAM…

I have been able to flash your file with a clip-on adapter, and my s1300 is working again.
If i get a poor wifi performance, because of a missing ART partition, I will use it as a VPN server :slight_smile:
Anyway I will try another think and if it works, I will post it here for any others looking for help.

Very many thanks and great support!!!

1 Like