Netgear M6 IP Pass > GL-MT3000 setup help

I am trying to connect a Netgear M6 hotspot MR6150 via IP Passthrough mode to my new Beryl AX via Ethernet.

I have followed the instructions from Netgear to enable this. It is really just click one box - “WebUI and go to Seetings → Setup → Mobile Router Setup → Under IP Passthrough, select ON” The Unit will then reboot. This also disables wireless.

The Netgear has an IP of and I am using the Beryl default IP of so there should be no conflicts. The Ethernet on the Beryl is configured DHCP. I expected/hoped some kind of a public IP to be available to the Beryl, but instead I get the following the Ethernet WAN interface:

Protocol: DHCP
IP Address:
DNS Server:
edit: I am sure this is due the CGNAT

I cannot get out to the internet. From a laptop connect to the Beryl I cannot ping the gateway. Any advice to get this working? I feel like I am missing something simple.


  • the Netgear Nighthawk works fine without IP passthrough turned on. I will get a 192.168.1.x address on the Beryl.
  • I would like to use IP Passthrough to take advantage of the Beryl’s superior AX performance among other things.
  • I realize that his is not a true “bridge mode” but falls somewhere in-between. I wish Netgear was more forthcoming about exactly what IP Passthrough does and offer a true bridge mode.

Thanks for any/all help.

It seems that the IP obtained here is not assigned by the ISP. What is the Internet access mode of Netgear M6 before this? PPPOE or DHCP, or other special Internet access methods

Thank you for your response.

It is DHCP, but the address is controlled by T-Mobile’s CGNAT that provides a private IP. This is pretty typical. The configuration on the SIM drives this.

They offer a static IP option at additional charge for business customers. I am exploring this to see it gives me the desired result.

Thanks again.

Why is DNS still Can you manually set the DNS address to or something else in MT3000.

Thanks for your reply - I have tried this with no success.

Ever tried using encrypted DNS?