New Beryl AX Light Flashing Cannot Connect

I have a new Beryl AX and I connect to the router wirelessly then apply a new admin password. After a few seconds, the router web page locks up, the light starts to flash at a one second intervals and I cannot access the router. I reset the firmware twice and the same thing happens. I wanted to use the device as a repeater connected to my main router. My first step would have been to update the firmware but I cannot see the web page for more than a few seconds, do you have any advice? Is this new unit malfunctioning? For the few seconds I saw the admin web page, I saw version 4.2.2 in the top left corner.
Thanks for your advice.

Could you also please confirm that updating the router firmware online while in repeater mode is reliable or should I use another method. Thanks,

When you change certain settings the router needs to reset itself. I that time it will kick you out or kick you off the wifi. Always double check which wifi you’re connected to when you save any changes or tell the device not to auto connect to any other signal but the gl.inet router.

Updating is always safe because the firmware is hash checked at the router before it is flashed.

Thanks for the feedback. In my case, I connected to the router over the default SSID and with the default password on the label. The first step is to enter a new admin password, I completed that step and could see the settings page of the browser. At that point, the router stopped responding to any input, the light was flashing and I could not reconnect. I did not have the opportunity to make any changes (other than setting a password). I reset the router with the hardware reset button and then repeated the exact same steps and was not able to work on setting up router or connect to the internet. I hope this helps to provide a better description of the situation.

Do you see the LED flashes quickly for a few seconds, then become solid?

If yes, then it is rebooted.

The first thing is to check the power adapter. Change to another one.

If the power adapter is changed and still have the same problem, it could be that the firmware crashes itself for some reason. Can you try set up using cable, so that it is not a wifi issue.

You can also try flashing the stable firmare using uboot GL.iNet download center

If still have issues, maybe contact customer service

I tried another power supply and a LAN cable with the same result.
I followed the UBoot process and waited 30 minutes. I reset the LAN interface, and navigated to the route welcome screen. I once again set a password, logged into router, router page was essentially blank. No information was coming up and could not reach the router.
Before and after the flashing process, the LED light is never solid, it always flashes at a one second interval. Because the router is new, I will start the return process.

I posted a few screen captures for reference.

You did refresh the page and login with the new credentials AFTER the fact?

Hello, Yes after restoring the firmware I refreshed the page but the menus are not responsive on the left side to any mouse selection.
After letting the router sit for 45 minutes with the light flashing, I removed the power supply to reboot the router with the same result. For my third attempt after the recovery, I reset the settings holding the reset button for more than 10 seconds, I was once again welcome to the router and reset the password, but still no response on the homepage.

About the LED status:

  1. When the router is booting, it will flash quickly for several seconds and then be solid blue.
  2. After the route boot, the LED will flashing once per sencond, indicating it does not have Internet
  3. Solid white: has Internet.

So is your router in status two? Flashing blue once per second? It means it does not have Internet.

How does your router ocnnect to the Internet? Do you have a cable?

Second, pls check your computer:

  1. Do you have multiple connections? i.e. one connection to the router and other connections to other routers? You can disconnect other connections so that your router use the right route to the router.
  2. Do you have vpn on the router? If yes can you disable that?
  3. When you have issues, can you check if you are still connecting to the router? It seems that you are disconnected. Pls check your connection and send me some images.

Third, do you have other devices that you can try? e.g. using your phone

Before flashing the firmware I connected to the router from a Mac mini using Safari both with Wi-Fi and with a network cable. I could successfully connect to the router for a short period of time and my next step was to establish an internet connection in repeater mode by using thee instructions

Unfortunately that is as far as I could get as shown in the screen capture, the router cannot locate any broadcast SSIDs in the area to connect as a repeater. I tried this with an iPad wirelessly and also with a USB-C to LAN adapter with the same result.

After flashing the firmware, I cannot access any of the menus. on the left side of the screen and the appearance shown in the screen capture is black and white and the date has moved from 2022 to 2021.

My goal was to connect to my guest Wi-Fi network which would be a similar situation when in a remote location.

At the moment the only way I can connect to the router wirelessly is by resetting the router and it will connect but I cannot see or use any of the menu options see attached screen captures.

Note that ALL settings are at default, there is no VPN. I have not been able to access any settings on the router as it does not respond. After flashing, there are no menu options, it is a blank screen as shown in the screen captures.

I do not have multiple connections when working with the Beryl router. My home router has a different default IP address (not For example when connected using the Mac mini, I shut off the computer’s w-fi and connected with a cable to flash the firmware locally. even after flashing, the Beryl router’s home page was blank and I could not select any items in order to set repeater mode.

Let me know if you have any other recommendations.

I did not answer one of your questions and I should note that the router is flashing once per second as it does not have internet. My goal was to connect as a repeater to my guest network but before flashing the firmware, it could not locate any local networks. After flashing, there are no menus available for selection.

One question, why is the router’s IP address It is by default.

Did you change it? Can you use the default one?

Another question, what is your browser?

Hello, I have never changed any setting including the default IP address. I used the during the initial welcome as shown in the attached screen capture. I also used as part of the flash process. The screen captures after the flash that are not coloured blue are reachable after the flash but they are not the default IP address for the router interface. When I use everything is working as intended.

I read the instructions except missed the default address after flashing the firmware. This is my error and I’m sure this is obvious to long time users of your system. Because of the Welcome screen and the flashing process, I thought that the correct address was 1.1 and not 8.1.

Thanks for your picking up on this detail. Using the router today, if I use the reset button to reset the admin password and go through the Welcome process on, it’s interesting that I am able to reach what appears to be the welcome screen but with no functions. This must be part of the design for the reset process.

1 Like

Well you could knock me down with a feather… I got something right! Woohoo!

1 Like