New Device: GL-XE300 (Puli) pretty slow

So overall pretty let down by this device… I don’t think the Quectel EC25-AF supports carrier aggregation (LTE-A) and that’s fine, given it has two internal antennas, I was expecting better speeds.

Samsung Galaxy S10 / GL-XE300
Band 2: 47 Mbps / 11 Mbps
Band 4: 45 Mbps / 24 Mbps
Band 12: 28 Mbps / 29 Mbps
Band 5: 8 Mbps / 9.1 Mbps

So with the exception of Band 12 the Puli (GL-iNet XE-300) get’s absolutely obliterated in speeds. Both were tested on WiFi 2.4 Ghz from my laptop to ensure a fair test.

11 Mbps? I might as well be on HSPA for all it matters.

All things considered this thing was way over price for what it is…
$119 USD
$29 USD
$38 CAD

All in a whopping $235 CAD for a device slower than a run of the mill Samsung I could just use as a hotspot and so much more. Really not impressed at all… I should have just bought a used Night Hawk M1100. LCD, external atenna connectors, 4x MIMO, LTE-A… :frowning:

You can check speed on cable? not 2.4G wifi?

The speed is roughly the same
24 Mbps on WiFi, with LTE band 4
25 Mbps on Ethernet, with LTE band 4

I think it just really is the limit of this device, single band (no CA). Not sure how to check of 2xMIMO is working though, since the samsung force on the same band does literally 2x the speed.

Can you edit the modem settings and set ttl as 65?

To my knowledge Rogers (or any Canadian provider - Bell, Telus) don’t throttle hot spot usage until you reach your plan limit, which I’m way under. Rogers will throttle you to 512 Kbps and Bell / Telus will just cut you off.

I tried using:
iptables -t mangle -I POSTROUTING 1 -j TTL --ttl-set 65

No real difference.

I am not sure if you had already solved your issue already, but I was facing the same issue with slow download speeds over LTE with my Puli device.

And just by switching to qcm protocol from auto in Manual setup configuration section in GUI, my download speed improved from 20mbps to 60mbps in average (using EP06-E WWAN module).


That’s fantastic news for the Puli, maybe they should change this configuration value in the firmware. So unfortunately my device had more issues than just this… I couldn’t ping it ( just sitting in front of it after about a day of use.

The customer service was nice and we setup a return, still waiting on a refund.

" And just by switching to qcm protocol from auto in Manual setup configuration section in GUI, my download speed improved from 20mbps to 60mbps in average (using EP06-E WWAN module)."

I agree. I changed to qcm and tripled my download speed using the EP06-E WWAN module on Vodafone in the UK.

Thanks for the advice.


Same problem here in China Mainland. After manually changed to qcm protocol, I have about +10mbps speed booster, about 20%.

Considered as I’m in a busy area, the speed test data offered by iPhone at the same time is 50mbps. The puli is about to offer 45mbps after to qcm, before that, the bandwidth is always around 20mbps.

Thanks for you advice.

It works so far so good and stable, fully fulfilled my requirements for both speed and stable and customization.

1 Like

Brand new GL-Xe300 (Puli, EP06-E LA), latest firmware

… inserted SIM in a 4G/LTE environment, in Europe/Switzerland.

The Puli gets max DL Speeds of 6-12Mbps, iPhone same carrier next to it 200Mbps.

Setting “ttl as 65” or “switching to qcm protocol from auto in Manual setup configuration” did not improve anything. Actualy worsened the speeds.

While connected to the Puli via Ethernet/Laptop, the speed to the LTE-Internet was no better than via Wifi/iPhone …

What can be done?

I don’t expect the same speeds like on the iPhone, but like at least half the speed? …
Or is it the antenna in the Puli? … Reception seems not so good … but I walked around in the open, same low connection speeds … the rssi seems pretty bad (-79)?
Bildschirmfoto 2021-05-12 um 20.38.11

any help is very welcome … maybe you know a “trick” @alzhao ?

rsrp is -111 which is pretty bad.

It uses band 20, which is 800MHz. In this frequency, it is hard to achieve 200Mbps even on your iphone.

So I think your iphone is using other band.

What you can try is to check what other band your carrier is using in your area and lock that band. You can do this in AT command section.

Thanks for the help @alzhao
I checked the other bands of the carrier (band 7 and band 8) they were no better …

Can you give the info on band 7?

looks like the other bands don’t connect to LTE/4G at all. The provider only uses 4G on band 20… so this is the “fastest” with ~ 10MB/s download … a reallly lame duck
band 7:

band 3:

band 8:

Band 20 is low frequency band. So it cannot achieve as high as 200Mbps.

To check the max speed on band, pls check 4G/LTE Throughput Calculator - Cellular Coverage and Tower Map

So your iPhone may are using multiple band aggregation.

Any way to check other band? For example band 1.