New gl-a1300 firmware

hi, i just received the gl-a1300, is there any firmware update somewhere or not yet ?

Hi,please download the latest A1300 beta firmware from this link:GL-A1300 beta firmware


Wow, the new 4.0.0 beta 2 firmware has “Drop-in Gateway Mode” now…
The Wi-Fi performance also improves a lot, nice ! :heart_eyes:


i have a error object when i click on your link !

Hmm, that’s weird, I choose keep settings option to upgrade firmware and everything is ok for me.

you can’t upgrade firmware automatically when is in beta, you have to do it manually

I thought the only way was manually?

Sure, it’s manually upgrade procedure.

1 Like

why i have this error when i click on the link to download the firmware ?

I have no idea. Try disabling https only mode or try a different browser

ok, didnt insist because i was thinking it was coming from the server

The upgrade worked for me and kept my settings also.

So congrats to GL-iNet, i must say this GL-A1300 has been built well.

Whilst i am waiting on a reply for a replacement power plug from EU to UK, i decided to open the router up as so i can install UART Header to the board and make a wire harness for it for ease of use.

I strongly suggest other do not try to do this with your unit as the chances of broken clips if not careful is quite high.

At the same time it also allowed me to look at the soldering job, now at least on my unit i can see that there is a possible issue that might happen with the USB-C Power connection if you are constantly inserting and removing the USB-C power cable. Yes its soldered down however it doesn’t have enough solder to anchor it to the board where it would be able to take the stresses that would be involved. One trip on the cable or unit falling off and i can see this USB-C connector following the cable which is a shame as the rest of the solder joints are spot on!

When i get new PSU plug i will fully test the firmware.

1 Like

Can you provide further details on your use case for “Drop-In Gateway Mode”?

I have been using the “Drop-In Gateway Mode” for few days and it really rocks although I have had no previous experience with it and not sure that I am doing it properly. Basically I am unable to work without my main router (Draytek) as I require WAN Link that GL.iNet does not support. The Draytek, however, lacks a lot of the features that the Slate AX supports and so I am forced into a terrible double NAT situation causing me all sorts of problems with remote access, VPN and routing policies. Now enter the black magic of drop-in gateway: My Draytek will handle all the NAT but my Slate AX can see all the IP client as if they belong to it. The Slate can work on all my network devices as if they are connected to it (when in fact none of them are in my case). I am therefore able to now use things like the DNS and VPN capabilities of my Slate AX on my network as well as the features on main Draytek router without having 2 separate networks. It has basically allowed me to amalgamate the features of the two different routers into one. The only problem I have found so far was that this feature does not respect the VPN policies although I have found a workaround for now.

1 Like

I am still trying to understand the purpose / implementation / use case of this mode as the description on the web UI.

However I found a similar wording “Drop-In Mode” on other vendor’s demo video which focus on redundant multi-WAN connections and doesn’t need to change current network structure.

I am wondering if this is the use case the new 4.x firmware want to provide. :thinking:

Video: (394) Support | How to Configure Drop-in Mode - YouTube

For me the download is empty tried with https and none, gonna check later on pc.

If I understand it correctly, the gl-inet router spoofs your default gateway’s mac address so every other device on the same network thinks it’s the default gateway/main router, so the devices send everything to your gl-inet router, their traffic can use the vpn tunnel, encrypted dns, etc… and then the gl-inet router will send everything to your actual default gateway/main router.

Correct me if I am wrong please.


It seems that Brave browser has issues to open the download page, since the built-in “Shields” treats the download URL is not safe one.

Turn off the Shields and it’s back to normal.




1 Like

Ah I see thanks !, I also noticed that the energy blu blacklist also blocked the domain in nextdns now I can see them :grin:

1 Like