New GL-MT6000 WAN keeps disconnecting (PPPoE Connection)

I just bought the new GL-MT6000 (Flint 2) and connected it to my ISP using their provided PPPoE credentials. While it connected and everything worked but after a few minutes it started disconnecting. The GL iNet Admin Panel gives the message that “No cable detected in WAN port”. If I remove an reinsert the cable, it connects but disconnects after a while again. I have tried changing the cable to FTTP box but same issue.
Now I am back to my old router which is running without this issue. (So, not a problem with the cable or FTTP box).
Please help, what could be the issue here.

Did you upgrade to the newest firmware already?
See here: GL.iNet download center

Yes, now it is running v4.5.8

Few further details. I have tried resetting the router. I connected using LAN directly to the router and also tried WiFi. WiFi and LAN connections seem fine. The only issue is with the WAN port that it randomly stops detecting.

It could be an issue with auto-negotiation because the WAN port supports 2.5 GbE by default.
You could try to use Ethernet 2 (and change the mode from LAN to WAN in GUI)

Unfortunately I am not sure how to set static speed on a port. Maybe @alzhao knows?

I tried connecting to second WAN port (and converted it from LAN to WAN), but had the same issue. Although, I think the second WAN port is also 2.5G so it can well be a auto-negotiation issue.

I did install it in the metal enclosure in the garage where ONT (FTTP) is installed and all ethernet cables are terminating. Due to lack of width in the box, I had to put it vertically.
Could it be because of the vertical placement or any interference from the metal enclosure? I cannot think of any other reason.

Bits & Bytes don’t care about the position mostly :wink:

bumping for visibility. The problem still exists without a solution.

Can you clone the old router’s mac address to the MT6000 and check?

Yes, already tried that. Didn’t work.

I think the issue is signal interference with the metal enclosure. Whenever, I close the door of the metal enclosure, the WAN links drops. Don’t know the connection between WiFi and WAN link, but I can’t think of any other logical explaination.

Metal should only affect wifi. Have no idea of how it affect cable.

Should you inform the VLAN?

There is no VLAN ID provided by ISP. And the WAN connection works fine when I turn off the WiFi. I was able to get it to work with only 2.4G wifi. As soon as I turn on 5G wifi, the WAN link drops.