New User of GL-AR300M

First, and importantly, I love the GL-AR300M. Once it’s configured and working, it works incredibly well. I have two questions I need assistance with, however.

[1] Unfortunately, I didn’t realize it only does 2.4 G and not 5G for wireless. I should have checked a little better. That’s usually not an issue but I work in IT and from home and 3 days of the week, I go to our local coffee shop. Their router is only setup for 5G so I can’t use the GL-AR300M. Is there a 5G dongle I can connect that works well until the module is ready?

[2] My second issue is this. Are there any “shutdown” procedure / steps to follow after configuring the GL-AR300M? I’ve only had it a few days now and every time I power it up, I don’t see my configuration and have to reset it all over. This obviously isn’t going to work.

Thanks for any assistance on this!

Brian Hendrix

You can check around for other threads detailing their adventures using 5Ghz USB dongles, such as this one.



As for the second issue, typing reboot should issue a soft reboot on the OS, which should “properly” shutdown everything and start it again. I’ve never found this to be necessary though.

If that doesn’t work, I would try re-flashing the firmware.

Maybe your router is not booting into NAND, but NOR instead? The boot medium changing would obviously change the configuration, too.

Have you tried re-flashing the NAND firmware?

You can download the stock NAND firmware for the AR300M on GL-Inet’s firmware pages.

If I recall correctly, you should be able to flash the NAND firmware by booting into the Uboot Web UI and selecting the openwrt-ar300m-nand-2.22.tar file.

You can find details/procedures about entering the UBoot Web UI here.


That’s about all I can think of, maybe somebody else has some better insight on this issue.

After buying the GL-AR300M, it did say that 2.22 was available and I followed the menu and applied it. Does that firmware upgrade do both NAND and NOR?

I don’t know, you would have to ask alzhao I think.

I’d still recommend reflashing the NAND firmware yourself using Uboot just to be certain though.

If you want to check whether or not you booted into NAND, you can type “df -h” and see how much space is available. If more than 100MB is available, then you booted into NAND.


I’m on a MacBookPro and simple did an SSH into (default) with root and here’s the output from “df -h”:

root@GL-AR300M:~# df -h
Filesystem Size Used Available Use% Mounted on
rootfs 102.3M 104.0K 97.4M 0% /
/dev/root 6.5M 6.5M 0 100% /rom
tmpfs 61.4M 988.0K 60.4M 2% /tmp
/dev/ubi0_1 102.3M 104.0K 97.4M 0% /overlay
overlayfs:/overlay 102.3M 104.0K 97.4M 0% /
tmpfs 512.0K 0 512.0K 0% /dev

In that case, you are definitely booted into the NAND.

Okay, this is getting frustrating. Everytime I start a new online “session” (new day or later in day) after plugging in the GL-AR300M, I am unable to get and stay connected. Today, my saved wireless connection (repeater) on the device was seen and I connected and then tried to setup at Starbucks with their 2.4G. For whatever reason, it wouldn’t connect to Google Starbucks so I unplugged the device and plugged it back in after waiting about a minute. I was unable to see my saved wireless connection. This is now EVERYTIME. I have to completely reset the device, recreate my configuration, and I will then work UNTIL the next time I use the device. Is there some shutdown procedure to this device? I’m simply unplugging it from power when I’m done using it.

@brianhendrix - Make sure you are using the most recent firmware. that was an issue with 2.20 (I believe). The updated 2.22 (and 2.21 beta) fixed what you seem to be describing.

What power supply are you using to power your device? Make sure that it is able to pull at least 5V and 1A. I am using a 5V 2A power supply for my AR300M.


Can you please tell me if running ‘reboot’ reboots it without causing any data loss? If you just want to shut it down, try ‘poweroff’, and then power cycle it whenever.

These would be the only ‘shutdown procedures’ that exist for OpenWRT.

It should give Linux some time to properly unmount and flush the filesystem.

If you are using EXT4 you will definitely find these commands useful, as an improper shutdown will mark your EXT4 filesystem as dirty.


I am using 2.22 (see below). I’m using an Anker Astro Pro Series power supply which provides 1.5A (12v) or 2A (9v). I’m set at 2A (9v).

Even when I finally get it working, I’m now seeing “drops” every 30-45 minutes where I have to reconnect. This is happening at two different locations where I work from. I haven’t even gotten to testing my VPN setup (


This device is supposed to be, for the most part, plug and play after getting most settings right. I should never have to login in to this device and run commands – ever, unless troubleshooting is required. I’m assuming you’re talking about start an SSH session to

Well, it appears to be that troubleshooting is indeed required judging by your issues.


When I refer to ‘run’, I mean run a command. To do that you generally need to be logged in to SSH unless you have another way to do it such as a serial console or maybe service that runs commands remotely.

So can you tell me whether or not the device’s configuration is saved after a proper Linux reboot?


If not, can you try changing your power supply out with something that provides 5V 1A and testing it then?


Disclaimer: I don’t work for GL-Inet, I just love their routers.

I do understand it needs troubleshooting, and I know what run a commands means. I work in IT as a Unix Admin. However, I wasn’t sure how you wanted all these steps to be performed when you did not give specifics and I’m not aware of how all these steps are to be accomplished – whether through the webpage or even “Advanced Settings” at the top of the web interface.

Here’s what I’ve finally found out. First, after a LOT of searching, I found an entry about the reset button. It turns off WIFI if you push it – didn’t know that! Second, I performed the reboot and waited and waited and waited and finally at 11 minutes post reboot, I finally saw the wireless show up for use. It did save the configuration. However, it took 11 minutes to get to it. I hope that’s not normal. It should be a LOT quicker. That’s what was fooling me – I never would have assumed I have to wait 11 minutes to see the device.

After some more testing, it also appears that “Autoscan and reconnect” didn’t reconnect me. I had to use “New Connection” to connect to the local public WIFI. I was hoping at the two locations I will be using this at the most would be recognized and reconnect on power-on of the device. An FYI – I waited an additional 7 minutes (18 total) before finally doing the “New Connection” option. I could have waited longer, I guess, but if it always takes 18 minutes (probably longer), it’s not worth the wait.


YOU WANT A 5V POWER SUPPLY FOR THIS DEVICE. 1A should be sufficient. Try connecting it to your PCs USB for now if you do not have one. Specs:

We can come back to the other issues, if they still exist after.

Yes, I know the specs.

This all began with the device running from the USB port of my MacBookPro. I used it from the USB port for days where all these issues started. I moved to the power supply as part of the troubleshooting just yesterday with no change.

I am not clear if you have tried a known good 5V 1A or better device as yet. If I recall USB2 power spec is 500ma and USB3 is 900ma so these may also be a problem, though I would hope not.

Some of the other unanswered questions.

You need to flash both parts, though I do not see anywhere it says they need to be the same firmware. They will have separate configs. I have not seem any info on how to choose the different flashes for booting (dual boot).

I read something about trying to boot 9 times before going to the alternate flash. At about 1 min per cycle this could mean that you are booting to the NOR as it can not boot the NAND (only a swag), but post 29585 indicates otherwise. What do you see in the app repo bar graph?

I agree, in general you should not need to SSH into the device once “operational”. There is no CLI console in GL.iNet or Luci gui, so to run commands Putty, WinScp or similar is needed.

I tried the “poweroff” command on my AR-150 and it seems to turn off the logic, but not the device. What happens with reboot and poweroff? This needs to be done from the CLI. There is an OpenWrt package called luci-app-command that will let you save commands to a list and run them from the Luci gui. Not what you want, but good to know.

The Saved Stations are in a file called \etc\config\ssids.

The “autoscan and reconnect” just enables and disables the function. It’s a toggle, not a button. If it’s off and you reboot, the device will not connect to a saved station, but the last station configured will get disabled if it can not be found. If the button is checked, it should try the configured station first, then cycle through the list looking for a station to connect to, which I think is the strongest signal, but not sure.

Re your comment in 29734 about the New Connection. If you have previously connected to the STAtion, then you should be able to connect to it from the Saved Stations button\popup under Settings=> Internet Status. Try Select to a know available Station. There is a bug (maybe, maybe not) in the GUI and the window does not close, so after about 45 seconds manually close it or refresh the window. For me I can reliably connect to the “Saved Station”, but I am on a different device (MIFI)

Finally at the bottom of the page is the service email:

Well, I made a trip to Best Buy for some other things and while there, I bought a PocketJuice Endurance power supply. It’s got a capacity of 6000 mAh but more importantly, it’s 5V/2.4A Max.

I haven’t had a chance to try it yet. I’ve been swamped with work and haven’t had time to “attack” it again. Once this is working and stable, however, my even bigger issue is the one coffeehouse I work from 3 days a week has chosen to NOT provide 2.4GHz WIFI – only 5GHz.

Do you know of any 5GHz USB dongles that are known to work well with these mini-routers especially the GL-AR300M?

Nice looking rig!

I have been looking for same and not found anything that seems to have any cred behind it

@brianhendrix, Sorry for replying this post late. Here is some comments:

  1. Data lost when unplug power: this happens only in Nand version AR300M in v2.20 and earlier. Because it is nand flash so the system cache data for some time before writing to the Nand flash. So if you unplug power before the data is written, data will be lost. This problem has been solved in v2.22, we forced the data to write to flash when you make some changes. This should works for saved stations as well.

This does not happen for Nor flash version because data is not cached.

  1. You can do a firmware reset in v2.22 if you kept your setting when you upgrade from v2.20. Some old setting may not work in v2.22. Repeater connection should be very quick and happen in less than 20 seconds. Sometime for unknown reason it cannot connect to a known network and will blacklist it so you will need to reboot and clear the blacklist. If you need several minutes to connect that is really not normal. Either it is a bug or it is something we didn’t test here.

  2. When you upgrade online or manually from the firmware, it only upgrade the firmware you are using. For example, if you upgrade from Nand version and you will only upgrade the nand firmware.

  3. The reset button behavior has been changed from v2.22. Sorry I haven’t make this available everywhere.

When you press the button down the middle LED will start to flash once per second.

When the middle LED flash quickly after 3 seconds, you release your finger the router will reset its network setting: disable repeater, set cable, enable ap.

When the middle LED flash more quickly after 8 seconds and you release your finger, the router will revert to factory settings and clear all your data.


I finally got this device to keep settings stored. I’m assuming it’s the new power supply I’m using.

However, now I’m experiencing “invalid password” errors even though password is correct AND unable to connect to wireless. The ONLY thing that fixed that was changing mode from 150M to 300M. Both should have worked.