NextDNS CLI Update


I’m using the Slate AXT1800 on V4.2.0.
It’s possible to install the NextDNS CLI on this version, however it’s a bit dated. Currently on your repo the version is 1.37.11, and the latest is 1.39.4.

Could you update the plugin to the latest version?
When I tried doing it manually by uploading the IPK in LuCi, it showed me that the gl.inet repo told LuCi the app was already running the latest version (which it was not).

I then tried the official setup method provided by NextDNS github page (OpenWRT · nextdns/nextdns Wiki · GitHub) but that didn’t work either, it refused to update:

Thanks in advance for your time :slight_smile:

I checked the change log for the openwrt package and noticed that it had been updated a short time ago.

You can download the latest ipk directly from the link below and install it on luci’s software repository page.

1 Like


Thanks for pointing me in the right direction! Sadly it does not seem to work, by both installing it & running the command, it gives me the following error:

Error relocating /usr/sbin/nextdns: __nanosleep_time64: symbol not found

It looks like you’ll need to upgrade libstdcpp at the same time. Unfortunately, openwrt doesn’t come with a corresponding installation package, so you’ll have to wait for the openwrt version to be fully upgraded before you can use the latest nextdns.

You can try to upgrade stdcpp in the link below, but it is important to note that this may cause the system to crash, please be careful

1 Like

Alright, then I’ll wait for that :slight_smile: Thanks for your help :pray:

My previous answer is wrong. The reason for this error is that ipk compiled on 64-bit system is used on 32-bit system. I try to compile an ipk locally for you.

Please install the ipk file in the link

You may need to use the following command to remove the original nextdns

opkg remove nextdns  --force-remove


1 Like

Thank you very much! It’s working perfectly! :slight_smile: