Nextdns does not apply

Hi, I have the GL-AX1800 FLINT router and I would like to insert the NEXTDNS personalized DNS. I follow the online guide, I insert ID Nextdns Click applies and gives me the following error: “Before activating this function, deactivating the other DNS settings” and among the manual setting there is DNS Server1:…

I tried to eliminate 127 … replacing it with Next’s DNS, but it doesn’t work.
How to solve the problem? Thank you

  1. check if the “Stubby” (DoT) is running or not and what port is listening to ?
    ( ps | grep stubby ), (if something wrong happens, please check system log to see what it complains about)
  2. If Stubby is running ok, please check the current DNS setting (Luci → Network → DHCP & DNS → DNS forwardings (delete the unnecessary ones and check the order of listing (if multiple DNS forwarding applied)

I solved. I had active AdGuard Home and went into conflict. So I deactivated AdGuard and no more longer that error.
Thanks for the reply

1 Like