No 1GBps speed from WAN

Hello,
have a problem which I can not solve.
I have 1Gbps ISP wan connection via PPPoE.

Tested directly on modem and I get speed app 800-900mbps. Used same cable to test speedtest from modem to PC.
2)All lan connections (router-switch-my PC) are 1Gbps. Confirmed on all devices that they connect 1Gbps. Used same cable to test speedtest form modem to PC.
But when I run speedtest on my PC (tried a bunch of them all the same result) I get max 100mbps speed. No SQM enabled. Router is Flint2. Please help!

Other relevant info:

"kernel": "5.4.238",
        "hostname": "GL-MT6000",
        "system": "ARMv8 Processor rev 4",
        "model": "GL.iNet GL-MT6000",
        "board_name": "glinet,gl-mt6000",
        "release": {
                "distribution": "OpenWrt",
                "version": "21.02-SNAPSHOT",
                "revision": "r15812+1082-46b6ee7ffc",
                "target": "mediatek/mt7986",
                "description": "OpenWrt 21.02-SNAPSHOT r15812+1082-46b6ee7ffc"

Network:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr 'xx.xx.xx.x'
        option netmask 'xx'

config globals 'globals'
        option ula_prefix 'xxx::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'lan5'
        option macaddr 'x'

config device
        option name 'lan1'
        option macaddr 'x'

config device
        option name 'lan2'
        option macaddr 'x'

config device
        option name 'lan3'
        option macaddr 'x'

config device
        option name 'lan4'
        option macaddr 'x'

config device
        option name 'lan5'
        option macaddr 'x'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask 'x'
        option ip6assign '60'
        option isolate '0'
        option ipaddr 'xxx'

config device
        option name 'eth1'
        option macaddr 'xxx'
        option mtu '1492'

config interface 'wan'
        option device 'eth1'
        option force_link '0'
        option ipv6 '0'
        option classlessroute '0'
        option metric '10'
        option proto 'pppoe'
        option username 'xxx'
        option password 'xxxx'
        option vlanid '0'
        option disabled '0'
        option peerdns '1'
        option mtu '1492'

config interface 'wan6'
        option proto 'dhcpv6'
        option device '@wan'
        option disabled '1'

config interface 'tethering6'
        option device '@tethering'
        option proto 'dhcpv6'
        option disabled '1'

config interface 'wwan6'
        option device '@wwan'
        option proto 'dhcpv6'
        option disabled '1'

config interface 'guest'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr 'xxxx'
        option netmask 'xxxx'
        option ip6assign '60'
        option multicast_querier '1'
        option igmp_snooping '0'
        option isolate '0'
        option bridge_empty '1'
        option disabled '0'

config interface 'wwan'
        option proto 'dhcp'
        option classlessroute '0'
        option metric '20'

config interface 'secondwan'
        option ipv6 '0'
        option proto 'dhcp'
        option metric '15'
        option force_link '0'
        option classlessroute '0'

config interface 'secondwan6'
        option proto 'dhcpv6'
        option device '@secondwan'
        option disabled '1'
        option metric '15'

config rule 'policy_direct_rt'
        option lookup 'main'
        option suppress_prefixlength '0'
        option priority '1100'

config rule 'policy_default_rt_vpn'
        option mark '0x8000/0xc000'
        option lookup '8000'
        option priority '1101'
        option invert '1'

config rule6 'policy_direct_rt6'
        option lookup 'main'
        option suppress_prefixlength '0'
        option priority '1100'

config rule6 'policy_default_rt_vpn6'
        option mark '0x8000/0xc000'
        option lookup '8000'
        option priority '1101'
        option invert '1'

config rule 'policy_default_rt_vpn_ts'
        option lookup 'main'
        option priority '1099'
        option mark '0x80000/0xc0000'
        option invert '0'

config rule 'policy_relay_lo_rt_lan'
        option lookup '16800'
        option in 'loopback'
        option priority '1'

config device
        option name 'pppoe-wan'

Wireless

config wifi-device 'mt798611'
        option type 'mtk'
        option band '2g'
        option htmode 'HE40'
        option channel 'auto'
        option txpower '100'
        option country 'xxx'
        option random_bssid '1'
        option disabled '0'
        option legacy_rates '0'
        option hwmode '11g'

config wifi-iface 'wifi2g'
        option device 'mt798611'
        option mode 'ap'
        option network 'lan'
        option ifname 'ra0'
        option wds '1'
        option isolate '0'
        option ieee80211k '1'
        option bss_transition '1'
        option ssid 'xxx'
        option hidden '0'
        option encryption 'sae'
        option key 'xxxxx'
        option disabled '1'
        option macaddr 'xxxxx'

config wifi-device 'mt798612'
        option type 'mtk'
        option band '5g'
        option channel 'auto'
        option htmode 'HE80'
        option txpower '100'
        option country 'xxx'
        option random_bssid '1'
        option disabled '0'
        option legacy_rates '0'
        option hwmode '11a'

config wifi-iface 'wifi5g'
        option device 'mt798612'
        option mode 'ap'
        option network 'lan'
        option ifname 'rax0'
        option wds '1'
        option isolate '0'
        option ieee80211k '1'
        option bss_transition '1'
        option ssid 'xxxx'
        option hidden '0'
        option encryption 'sae'
        option key 'xxxx'
        option disabled '0'
        option macaddr 'xxxx'

config wifi-iface 'guest2g'
        option device 'mt798611'
        option network 'guest'
        option mode 'ap'
        option ifname 'ra1'
        option guest '1'
        option wds '1'
        option isolate '1'
        option disabled '0'
        option ssid 'xxxxx'
        option hidden '0'
        option encryption 'sae-mixed'
        option key 'xxxx'
        option macaddr 'xxxxx'

config wifi-iface 'guest5g'
        option device 'mt798612'
        option network 'guest'
        option mode 'ap'
        option ifname 'rax1'
        option guest '1'
        option wds '1'
        option isolate '1'
        option disabled '0'
        option ssid 'xxxxx'
        option hidden '0'
        option encryption 'sae'
        option key 'xxxx'
        option macaddr 'xxxx'

DHCP

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option rebind_protection '0'
        option filter_aaaa '1'

config dhcp 'lan'
        option interface 'lan'
        option dhcpv4 'server'
        option ra_slaac '1'
        option force '1'
        option dhcpv6 'disabled'
        option ra 'disabled'
        option ignore '0'
        option start '200'
        option limit '50'
        option leasetime '720m'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config domain
        option ip 'xxxx'

config domain
        option ip '::xxxxx'

config dhcp 'guest'
        option interface 'guest'
        option dhcpv6 'disabled'
        option ra 'disabled'
        option start '200'
        option limit '50'
        option ignore '0'
        option leasetime '720m'

config dhcp 'secondwan'
        option interface 'secondwan'
        option ignore '1'



Firewall


config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option output 'ACCEPT'
        option forward 'REJECT'
        option mtu_fix '1'
        option input 'DROP'
        option masq '1'
        list network 'wan'
        list network 'wan6'
        list network 'wwan'
        list network 'secondwan'

config forwarding
        option src 'lan'
        option dest 'wan'
        option enabled '1'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'

Hi,

Hmm, is the pc the only device reaching 100mb/s or all?

Also you said that you have checked that all ports are 1gb/s, including the switch, do you mean you also checked on negotiation rate?

A little off topic:

I was thinking lately since i might want to upgrade my equipment in the future, also about how they terminate patch panels especially since newer cables don't like any core exposure, they need keystones now to properly shield because these older patch panel ports may won't negotiate anymore on these newer speeds plus the core exposure on cat6+ is actually not usual.

now comes my realization: besides some households may still have bad cables with bad terminated coring (i don't think this is your issue, maybe on its slights a 100mb cable), but maybe they also have a old 100mb/s backhaul patch panel?

Actually it's something very overlooked, but i have seen a few US videos of homes which had it, which is for me unusual but likely very normal in some places.

Could the patch panel be the issue if any?, because 100mb/s is a very generic value.

Just to be clear. Is there a switch between a Flint 2 router and a PC??

Remove the switch out of the equation and connect your PC directly to the Flint 2 router.

1 Like

negotiation rate on all devices is 1000mbs full duplex

Have tried that. Still 100mbs.

Are you sure you're not confusing bits and Bytes?

Is the ip in the proper range or has it been assigned some random ip that isn't in the pool?

Does it do the same on dhcp?

no all is mbps. DHPC works fine. For mine PC have manual ip.

I am assuming your PC is a windows client? Have you check your network adapter on Windows to see what the link rate is reporting there?

You can also try the "ethtool" command. Navigate to Luci and login (same gui username / password) find: Network > interfaces and then look for the interface name in question, for example eth1

Load a terminal Window (Termius app on android is good or Putty for Wiindows) Login to the router and run this command (changing "eth1" to the interface port names you wish to check)

Command:

ethtool eth1

This will then report the stats on the port which might help diagnose a little further.

Please run a speedtest on the router itself to see if the router is already part of the problem:

I get:
Settings for pppoe-wan:
No data available

Strange. Check the correct interface name. I'm sure yours is eth1. Also follow @admon post.

If your capping at 100mbits then it must be something to do with cable or link speed negotiation as it's too coincidental that it's around the same figure / speed as a "fast ethernet" link.

do not have eth1 interface. Checked cables. Negotiation shows on all ports/devices 1000mbps full duplex. Like said tried with same cable speedtest from modems which shows 600-800 mbps. Then tried with laptop on router which shows 80-120mbps. Same on my desktop PC. Yes is strange issue.

Please check on the router itself as well. Run those commands I linked.

ok. Found it. It was Packet Steering option. When I disabled it everything is ok. Thnx for help everyone.

When you say you disabled it, what exactly did you do, which settings and where? Reason I ask is that it might be helpful for others if they have the same issue.

I just uncheched box in Luci. Network- Global network options

Ah ok. Surely this shouldn't be required, maybe it's a bug in the particular firmware you are running...at least you have figured out a fix for now.