No connection to connected devices

Hello, I have connected 2 Flint routers in different locations via goodcloud. A flint router (flint 2) is connected directly to the internet access point (has no public ip), the other (flint 1) is connected to a router from another provider (with a public ip). Flint 1 receives its ip from the third-party router and issues the ip for its network to the connected devices. See diagram. In Goodcloud, both flint routers are green and I can access the remote flint 1 router from flint 2. The devices attached to the remote flint 1 router show up in the client list with green ticks, but I can’t access them. I can’t ping these devices either. It worked last year - but I don’t know why it doesn’t work now.

Please check Flint2’s route table, run command on Flint2 to see if there’s any conflict:

ip route
  1. To supplement: I have already tried to access the clients at Flint 1 with another Brume router in another network. Also without success.
  2. How and where to enter the “ip route” command?

Then it’s more likely the issue of flint1.
Run command by ssh:
refer to

Thanks. I’m not at the Flint 1 location right now. Can’t remotely access Flint 1 via ssh? I’ll try it out when I’m back at the Flint 1 site - in about 4 weeks. I’ll get back to you then.

Sure, you can use remote ssh if you’ve already enabled goodcloud. like this

I accessed flint1. The command “refer to” brought no result. The command"ip route"

brought the attached result. What can one deduce from this?

After debugging with Sole, we found the firewall rule that allows s2s traffic is gone for some mystery reason. Added that back by command:

uci set firewall.s2s_rule_udp=rule
uci set'Allow S2S UDP'
uci set firewall.s2s_rule_udp.dest_port='51830'
uci set firewall.s2s_rule_udp.proto='udp'
uci set firewall.s2s_rule_udp.src='wan'
uci set'ACCEPT'
uci commit firewall
/etc/init.d/firewall reload