No Device Detected for USB connection to AXT1800

Running the latest Beta build: openwrt-axt1800-4.2.3-0801-1690857361

After connecting a USB disk to the router, Network Storage continues to show “No Device Detected”.

Looking in the System log I can see the device recognised, but still not showing in Network Storage.

Sorry about the screenshot, but you can see that the Export Logs button has disappeared.


How odd. It looks like there are two partitions on the USB drive (sda1 & sda2). That may have something to do with it. You should really check via SSH so you can get at the logs via logread &/or dmesg & check status via lsusb & blkid, etc. See the following for a pertinent guide:

I also tried with a second USB drive with a single partition, same result.

Is that really going to show anything different from what I’ve already posted from the system log. Answer, it didn’t while I was ssh’d into the router.

Don’t know about blkid as I didn’t try that, but lsusb isn’t part of the image. Nor is (c)fdisk which I also tried to see what the underlying OS thought about the disks.


What filesystems are supported.


Right; sorry. It’s been a while. Try opkg update && opkg install usbutils

ExFAT & NTFS, IIRC. I’m currently using a uSD w/ exfat ATM. Something like F2FS requires pulling fr the repos, of course.

What shows up in LuCI → System → Mount Points (GL GUI → System → Advanced Settings)?

Finally got it to work, by using a new freshly formatted drive. I tried with both ext4 and NTFS and both appeared to work.

Now I have a disk that connects reliably, I’m going to experiment with the multi-partition to see how that is handled.