No devices can see or connect to 5Ghz on GL-AXT1800 after renaming SSID

If I firmware reset the router then my laptop can see the “5G” SSID and connect to it successfully.

But if I then change the SSID (to “BigPaua5” - nothing fancy) no devices can see it or connect to it.

I’ve repeated this flow several times to confirm. Firmware reset; connect laptop to the “5G” SSID; change the SSID; can no longer connect.

I can rename the 2.4Ghz network (I set that to “BigPaua24”) and connect without problems. It’s only renaming the 5Ghz that causes this issue.

What’s up with that? Thanks.

Edit: Router’s firmware is 4.2.1

After renaming the said, did you remove the old profile in your devices ?

What 5 Ghz channel are you selecting? Sometimes the 5 Ghz signal will “disappear” for some devices if the router is set to a DFS channel (52-144).

@RBzee, I initially tried it a bunch of times on “Auto”, ie everything left to the system defaults except for the SSID. (Though most times I also changed the password too, but not every time, just in case changing the password was triggering some bug).

I also tried it on a range of different manually set channels, both DFS channels and not. None of that seemed to help.

I also tried changing the wifi modes, as well as the transmit power, and bandwidth. Again, none of this made a difference.

@SpitzAX3000, yes, I tried both “forget this device” and manually removing the SSID’s password entry in macOS keychain.

During most of my tests I also had Wifi Explorer running, to see if the laptop could actually see the router’s 5Ghz SSID at all. In all cases it wasn’t showing up in Wifi Explorer (and still isn’t now).

I’ve just this moment tried changing the 5Ghz SSID to “TestTest”, to see if somehow macOS is still remembering the old SSID and messing up on it somehow. But that’s also achieved nothing - still not showing up in Wifi Explorer or macOS’s wifi networks list.

It could be a bug as you said. Can you please upgrade to the latest beta firmware and try again .

Thanks for the tip. I found the beta firmware and installed (4.2.3). Though unfortunately it hasn’t helped.

I might experiment with leaving different settings on for several hours each. For example changing to a manual channel then leaving that for several hours, to see if any devices eventually see it. Then trying a different change, and repeat until something works.

Though if a setting change doesn’t make the network show up in Wifi Explorer within a few minutes, it seems like it’s not going to in a few hours either. But I’m running out of things to try.

Reset you modem settings to default. Then login into Luci at:

And rename the SSID from there by clicking edit. Test and let’s know.

1 Like

Well that was interesting. Though it didn’t solve the problem, but at least I’m learning more.

After doing firmware reset I confirmed that I could stay on the default 5Ghz network for an extended period without issue (about 30 minutes). Then I tried as you suggested, and renamed the SSID in Luci (to “BigPaua5”).

After renaming it it briefly showed up in Wifi Explorer, but then disappeared. Curiously, I think it was on the same channel as before I changed the SSID (channel 36). So it doesn’t seem to be a channel thing. Well, unless it started on 36 then changed to something else, at which point my laptop couldn’t see it anymore. I guess that’s plausible.

Here’s a screenshot of the changes Luci applied. Presumably one of the changes other than the SSID is causing a problem. Though I haven’t seen a way in Luci to hand edit those config lines yet.

Well this is curious. I decided to leave everything at firmware defaults, and connect all my devices to the 5Ghz network like that for now. Which did work fine for 10 minutes or so. But then eventually the network disappeared, with each device dropping off, no longer able to see it or connect.

And even more curiously, the devices that I’d configured to use the default 2.4Ghz network (because those particular devices don’t support 5Ghz) also started dropping off, unable to connect to the 2.4Ghz after 10-20 mins or so.

No idea what that’s about.

I’ve now reconfigured the networks back to my own naming and password scheme, and reset/reconfigured my various devices to connect back to “BigPaua24”, and they’re all happy again.

The 5Ghz default network eventually disappearing I guess might make sense if it auto migrated to a new channel that my devices don’t support / can’t see. But the 2.4Ghz network also disappearing… that seems more odd. Unless in the 2.4Ghz range there’s also channels that some devices don’t support?

My devices were mostly bought in Thailand, while I bought the GL-AXT1800 in Japan, and I’m currently living in Indonesia.