No Internet w/ Wireguard/PIA VPN set up via Mobile App


I bought a Mini Smart Router (GL-ARM300M16) aka the Shadow I believe.

I need to set it up as a physical VPN. I downloaded the mobile app and tried to set up Wireguard – added my Private Internet Access (PIA) login, and it appears to connect, but then there is no internet.

I tried setting up OpenVPN via the browser as well, using a file downloaded from PIA. No internet there as well.

My VPN account is active and works on my computer.


What is your firmware version?
I have a screenrecorder below for your reference.

Please make sure the GL-AR300M16 can access the Internet before turn on the VPN.

Yes, I followed these exact steps. I think it’s some other issue.

I have internet through the Mini Router up until the point where I enable the VPN.

It appears that I didn’t have the latest firmware – I’m updating now.

It also appears there is an issue with the timezone – not sure if that would cause an issue. Where can I update the timezone of the router?

Thank you.

OK, I have updated the firmware to 3.212.

Reset the router and tried to enable the VPN again. Once again, no internet.

The Time Zone section still says “Router timezone differs from your browser” on the mobile app. When I press the Sync button, it says “ERROR: Invalid parameter, value or format!”

When I set up the router initially, I did change the time zone via my desktop. It was UTC.

Still not sure if this is linked to the issue or if it’s something else entirely. Thanks!

It looks like there is a bug with the time zone in the app.

May I ask what is the app version? The latest version is 1.2.01

What is your time zone?

It is an android phone or iPhone?

I think the time zone isn’t the reason for the VPN.

I don’t know why your PIA didn’t work for now, but it tested fine on my end. I will try again and let you know when I find out why. If you have some new findings, please let me know, thanks.

Thanks for your reply!

The app is version 1.2.01. On iPhone – although it is not running on the latest iPhone OS. Could that somehow cause a problem? :confused:

My time zone is PST.

Nothing new to report here… the only thing I can think to try is to get a trial account with another VPN and see if that works or not.

I don’t know if this will help but I had what appears to be a similar issue with using PIA. My E750 would work for a short time then would drop the upstream connection. Even after I thought I disabled the VPN, the issue persisted. I ultimately did a hard reset to clear the device and am not using the VPN feature.