No internet when VPN is on

I have a GL-SFT1200 Opal. I’ve connected PIA VPN over both OpenVPN and now Wireguard (separately) and when the VPN is switched on and enabled, despite it saying that it’s connected, client devices have no access to the internet. The access is restored when the VPN is switched off. How can I make this work?

if you have no internet does pinging to a ip address still work or not? i.e ping

Or does it affect both domain and ip resolution?

I am having the same issue with my Opal. When the Wireguard Client VPN is on (with allowed IP’s set my my local network on the VPN Server) I have no internet connectivity - but I am able to access the remote local network.
Since is not local, but rather on the internet, the answer is “No. It is not pingable”.
If I set allowed IP’s to then it functions fine - with the exception of the fact that ALL internet traffic goes through the VPN Server, which is not what I want.

Well, the integrated VPN client is more for VPN providers than connecting S2S.

Make sure to disable the Block Non-VPN Traffic switch in the VPN global options:

If this doesn’t work you can switch to VPN policy VPN Policy Based on the target domain or IP and list there your network like

Got it. My bad. Brain fart. I forgot to change the settings from “Global” to “Auto Detect”.
Works fine with the settings correctly configured.