No option to choose Tailscale as the source for port forwarding

Trying the latest beta firmware v4.5.8 on the Flint 2 to see how it would compare to my previous favourite firmware v4.5.4. First noticeable difference is the lack of option to choose Tailscale as the external zone sourse for port forwarding on the latest firmware. Any idea why this is and how to fix it? Thanks in advance for any input.

Maybe you need to connect first to Tailscale then go back to the forwarding page? Just suggestion as I have never used it though.

1 Like

Thanks. I have already connected to Tailscale as shown by the green dot next to it in my screenshot. The option to use its tunnel as the external zone for portforwarding was definitely there in the older firmeware.

Can you try LuCI:

https://router-ip/cgi-bin/luci/admin/network/firewall/forwards

No, unfortunately not there either:

Then, you can create a zone by yourself till the stable firmware is released:

https://192.168.8.1/cgi-bin/luci/admin/network/firewall/zones

FYI, I just enabled Tialscale on Spitz X3000 and there is no Tailscale option on the external zone. Are you sure, you had it on the older firmware?

This is how you can create a zone for Tailscale:
https://openwrt.org/docs/guide-user/services/vpn/tailscale/start

UPDATE: before creating such zone for TS, I would try to create port forwarding on the WAN external zone first and see if ti works.

1 Like

That is most helpful as I have no experience with Luci. I have done the following:

Looks fine but are my settings the correct ones for it to function properly?

Enable Tailscale and test whether it works.

Does not seem to be working. Not sure where I have gone wrong but more importantly unsure as to why this option has been removed or omitted from the new official GL.iNET UI.

Did you create an interface (not Zone) as per the instructions? And did you read the Workaround and How to setup a Subnet Router/Exit Node sections?

Followed the instructions by creating an interface and not used the router as an exit point at all. Noticed on a separate note that VPN was also slower than usual and so went back to flashing v4.5.4 on the router which appears to have fixed there issues. Will stick with this version (which I also understand is based on a newer kernel anyway) for now and thank you again for all your help and sharing the tips.