**no reconnect wireguard client**

I have the following problem: I have a gl-inet “creta” attached to the fritzbox (7590)as a wireguard server and I want to set up a VPN with my gl-inet “spitz” (client) while on vacation. That works too, but I have to disconnect and reconnect the VPN every morning. Can someone here help me and explain what I’m doing wrong?

ich habe folgendes problem, ich habe einen gl-inet “creta” als wireguard server an der fritzbox (7590) angehängt und möchte im Urlaub mit meinem gl-inet “spitz” (client) ein VPN aufbauen. Das funktioniert auch, aber ich muss jeden früh den VPN trennen und wieder neu verbinden. Kann mir hier jemand helfen und erklären, was ich falsch mache?

It can be you should do the follow on Fritzbox:

  • set your dayly reconnect for DSL to 3:30 or 4:30, thats can be it reduce your troubble a verry, verry little bit
  • If you use newer Firmware like 7.24 or 7.25 or so on, disable “force check DNS certificate”. Thats still not working 100% stable on this firmware versions.

For force reconnect VPN by gl router, lets look what the gl service say.

Thanks for the Info, i have now 7.27 on my fritzbox, so i am waiting of Service from gl-inet or other…

I dont know test results about the 7.24 firmware version from AVM, so it can be this point are fixed now or still not 100% stable.

now I still have a problem, I wanted to restart the wireguard server stopped it on the creta and wanted to restart, now I always get the error “wrong IP”?

Now I have reset the creta over the VPN of the Fritz box and now I have no access at all, now I have to wait until I am home again, that does not seem to work over the vpn

I suggest that you bind the device to you Goodcloud.xyz account. So when vpn does not work you can still remote to it via cloud (using 3.201 firmware).

If you vpn breaks everyday seems that it is your carrier. Does your IP change?

Yes, the IP changes at night, but I have “myfritz” dyndns via the Fritzbox, maybe it will work after the reset, I’ll have to try it next week when I’m back home and can set up Creta again!
But if I use the GoodCloud and reset the router, isn’t the Cloud gone too?

Let’s say that Goodcloud use a different way to manage routers.

When your vpn breaks, the cloud may not break as well. But have to try and see.

it’s the same problem here. After the wireguard client got disconnected (because of server ip change), it should resolve the name again before trying to reconnect. i feel that this is a bug.

That is standard OpenWrt Wireguard behaviour. The /usr/bin/wireguard_watchdog script has been developed to be run every minute in cron:

I do not work for and I do not have formal association with GL.iNet

I think in GL.iNet stock firmware, this is fixed in 3.211.

I am using 3.212 from last week.

You another post indicate that you are using MT1300 and have problem connecting to gn network.

I wonder if you can combine the problems and we can discuss together.


  • MT1300 with 3.312 beta1
  • has problem connecting to 802.11ng networks
  • wireguard cannot reconnect if internet drops or unstable

Do you have any info about your wireguard server? Which service provider is that?
Can you reset the router and config again so that no config is kept from upgrading.

regarding wireguard:

  • same problem with latest stable (MT1300)

  • also with 3.212 beta (MT1300)

  • also with latest stable on Mango v2

  • wiregurad server (GitHub - pivpn/pivpn: The Simplest VPN installer, designed for Raspberry Pi) on raspberry behind a router at home

  • I cleared the config for the update process to beta. no pitfall here.

  • workaround: cancel the connection attempt on gl-inet router, connect again => success

Regarding GN-Network problem:

  • TODO for me to reconfigure home router again and try a connection via RJ45 connection to MT1300 (today or tomorrow)
1 Like

Is there an update regarding this issue?
I have the exact same ussue with a MT300N-V2 (firmware 3.212) which is connecting (remotely) to a wireguard server on my linux server. Everyday, the router (Fritzbox 7490 with dynDNS) at the server site does a forced disconnect and reconnects after few minutes. However, the wireguard client gets disconnected (orange “connecting” sign in the app) and is unable to reconnect to the server. It seems to get stuck in trying to reconnect. When cancelling the “connection approach” in the app by hitting the orange button which says “connecting” it turns blue (“connect”) and I’m able to pressing it again to reconnect. Everything works perfectly, again. However, doing this everyday is not the most convienient solution :wink:.

I recorded this one on my list and will ask developer to do some test.

1 Like

Thank you very much, alzhao! I’m very impressed by the fast and constructiv reaction :+1:!
If there is more information needed, I’m happy to support!

I use a GL AX1800 router behind a Fritz!Box 7530 router connected to a fiber optic connection. The Fritz!Box router is attached to AX1800 via LAN.

The ISP disconnects the Internet at 04:00 am (forced disconnection). After that I have the problem that the GL AX1800 has no longer an internet connection. After a restart everything is ok.
Problem appears while connected to WireGuard.

It seems that this is a known issue. Is there already a solution for this problem?

GL AX1800 the newtest version:

the wg client will reconnect, if the wg client config “Endpoint” is DNS, when the wg server ip change, use the DNS can reconnect ok.

if the wg server is static ip, the wg client connect he invalid old ip, is not ok