No stable openwrt version for GL-MT300N?

I want to try testing the GL-MT300N again but all I can find is a trunk version for the device.

Am I missing something and there is in fact a stable version? I’m looking in the ramips sections.

I do see; GL.iNet download center

Does this mean a clean install without any of the gui and other settings pre-set?

the clean firmware from our website contains Luci, but no other packages.

You can use our fork of openwrt CC1505.1 GitHub - domino-team/openwrt-cc: openwrt CC with Domino/GL patches

We just added our target patch without touching anything else.

Unfortunately, we don’t have a full time person taking care of these devices so I am doing this work without much experience :).
What I need is a version where I can install the packages that we need. The trunk version causes problems for some reason.

Just use the clean version. It is backed by full software repository.

Doesn’t work for us. We need to create our own firmware with all of the files needed and files we need removed. It is a process of preparing the devices for shipping to customers. Adding the packages manually would take much too long.

It has an image builder. 404 Page not found - GL.iNet

The image builder is for this purpose. check this post as well: 404 Page not found - GL.iNet

Oh, I wasn’t able to find that. Thank you. I’ll try it tomorrow.

I downloaded the version you pointed out and used profile GL-MT300N but after building, see nothing for this model specifically.

-rw-r–r-- 1 nobody nogroup 3932164 Oct 14 06:40 openwrt-ramips-mt7620-e1700-squashfs-factory.bin
-rw-r–r-- 1 nobody nogroup 3932164 Oct 14 06:40 openwrt-ramips-mt7620-e1700-squashfs-sysupgrade.bin
-rw-r–r-- 1 nobody nogroup 2621440 Oct 14 06:40 openwrt-ramips-mt7620-root.squashfs
-rw-r–r-- 1 nobody nogroup 1196274 Oct 14 06:40 openwrt-ramips-mt7620-uImage.bin
-rwxr-xr-x 1 nobody nogroup 3555980 Oct 14 06:40 openwrt-ramips-mt7620-vmlinux.bin
-rwxr-xr-x 1 nobody nogroup 3560984 Oct 14 06:40 openwrt-ramips-mt7620-vmlinux.elf

What packages did you select?

When you make please add V=s to make and post the last part of log

This is the exact command I am using for this device.

 

make image profile=GL-MT300N PACKAGES=“bc vnstat libstdcpp ca-certificates libpthread bash curl -kmod-leds-gpio -wpad-mini -iw -wireless-tools -kmod-ipv6 -kmod-ipv6 -firewall -iptables -ip6tables -odhcpd -dnsmasq -kmod-ath9k -uboot-envtools -ppp -ppp-mod-pppoe -kmod-ppp -kmod-pppoe -kmod-usb-core -kmod-usb2 -kmod-ledtrig-usbdev -kmod-usb-ohci -kmod-usb-hid”

 

I also need a specific network setup of both interfaces being dhcp and pass-through. I’m having difficulty with that.
Therefore, I use files/etc/config/network also in the build.

Should I post it here or start a new thread.

Just post here

I posted the command I’m using to build.
Now, for the network, the factory network file looks like this;

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config globals ‘globals’
option ula_prefix ‘fd7e:46e5:dd59::/48’

config interface ‘lan’
option ifname ‘eth0.1’
option force_link ‘1’
option macaddr ‘e4:95:6e:40:70:86’
option type ‘bridge’
option proto ‘static’
option netmask ‘255.255.255.0’
option ip6assign ‘60’
option ipaddr ‘192.168.8.1’

config interface ‘wan’
option ifname ‘eth0.2’
option force_link ‘1’
option macaddr ‘e4:95:6e:40:70:87’
option proto ‘dhcp’
option hostname ‘GL-MT300N-086’

config interface ‘wan6’
option ifname ‘eth0.2’
option proto ‘dhcpv6’

config switch
option name ‘switch0’
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘switch0’
option vlan ‘2’
option ports ‘0 6t’

config switch_vlan
option device ‘switch0’
option vlan ‘1’
option ports ‘1 2 3 4 6t’

And I need to make this a dhcp pass-through configuration. Meaning that WAN port will pick up a DHCP IP from the upstream LAN side DHCP server and I should then be able to ssh into the LAN port side of the same DHCP IP.

So, how should my network file look? Should it look like the following?

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config interface ‘lan’
option ifname ‘eth0.1’
option force_link ‘1’
option type ‘bridge’
option proto ‘dhcp’

config interface ‘wan’
option ifname ‘eth0.2’
option force_link ‘1’
option proto ‘dhcp’

config interface ‘wan6’
option ifname ‘eth0.2’
option proto ‘dhcpv6’

config switch
option name ‘switch0’
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘switch0’
option vlan ‘2’
option ports ‘0 6t’

config switch_vlan
option device ‘switch0’
option vlan ‘1’
option ports ‘1 2 3 4 6t’

Your command generates a sysupgrade but not a factory build or any others for MT300N for that matter.
<pre class=“code”>404 Page not found - GL.iNet
<pre class=“code”>make image PROFILE=GL-MT300N PACKAGES=“luci-app-upnp openvpn-openssl kmod-usb-core” FILES=files/

ls -la bin/ramips/

-rw-r–r-- 1 nobody nogroup 4456452 Oct 14 16:28 openwrt-ramips-mt7620-gl-mt300n-squashfs-sysupgrade.bin

The build seems to run ok and eventually these errors show up and it ends.

if [ stat -c%s "/clients/gl-net-mt300n/build_dir/target-mipsel_24kec+dsp_uClibc-0.9.33.2/linux-ramips_mt7620/openwrt-ramips-mt7620-ex2700-squashfs-sysupgrade.bin" -gt 3866624 ]; then echo “Warning: /clients/gl-net-mt300n/build_dir/target-mipsel_24kec+dsp_uClibc-0.9.33.2/linux-ramips_mt7620/openwrt-ramips-mt7620-ex2700-squashfs-sysupgrade.bin is too big” >&2; else cp -fpR /clients/gl-net-mt300n/build_dir/target-mipsel_24kec+dsp_uClibc-0.9.33.2/linux-ramips_mt7620/openwrt-ramips-mt7620-ex2700-squashfs-sysupgrade.bin /clients/gl-net-mt300n/bin/ramips/openwrt-ramips-mt7620-ex2700-squashfs-sysupgrade.bin; fi
Warning: /clients/gl-net-mt300n/build_dir/target-mipsel_24kec+dsp_uClibc-0.9.33.2/linux-ramips_mt7620/openwrt-ramips-mt7620-ex2700-squashfs-sysupgrade.bin is too big
/clients/gl-net-mt300n/staging_dir/host/bin/mkdniimg -B EX2700 -H 29764623+4+0+32+2x2+0 -v OpenWrt -i /clients/gl-net-mt300n/bin/ramips/openwrt-ramips-mt7620-ex2700-squashfs-sysupgrade.bin -o /clients/gl-net-mt300n/bin/ramips/openwrt-ramips-mt7620-ex2700-squashfs-factory.bin
[mkdniimg] *** error: stat failed on /clients/gl-net-mt300n/bin/ramips/openwrt-ramips-mt7620-ex2700-squashfs-sysupgrade.bin
make[3]: *** [install] Error 1
make[3]: Leaving directory /clients/gl-net-mt300n/target/linux/ramips/image' make[2]: *** [build_image] Error 2 make[2]: Leaving directory /clients/gl-net-mt300n’
make[1]: *** [_call_image] Error 2
make[1]: Leaving directory `/clients/gl-net-mt300n’
make: *** [image] Error 2

only sysupdate firmare is useful and there is no factory.bin

you compiled too many packages and the firmware size is too big to generate the bin file.

I asked about this kind of problem in another post in these forums and the last time I was told not to worry about that error.

Anyhow, I’m removing more packages and trying again.

Ok, I’m there and have
openwrt-ramips-mt7620-gl-mt300n-squashfs-sysupgrade.bin

All I need last is to know the network config.

 

I’m not 100% sure if this is the pass-through config I want but I’ve flashed the device and it’s running our code with the following.

 

Does “pass-through” means you want to disable dhcp on the mini router and ask all clients to get IP from your main router? I.e. create a bridge dump AP?

There are some place you need to modify.

config interface ‘lan’
option ifname ‘eth0.1 eth0.2’

config interface ‘wan’
option ifname ‘eth0.2’
option force_link ‘1’
option proto ‘dhcp’

also disable DHCP in /etc/config/dhcp, find the 'lan' port and change igonore "option ignore 1"

Yes, I need a hardware bridge between the two interfaces, where one interface picks up a DHCP IP from the upstream device and where packets can be seen flowing in/out of the device so we can use tcpdump inspection for example.

Also, I hard code this change in the etc/config/network file and do not use command line commands since we build the firmware for multiple devices.

Currently, the file looks like this

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config interface ‘lan’
option ifname ‘eth0.1’
option force_link ‘1’
option type ‘bridge’
option proto ‘dhcp’

config interface ‘wan’
option ifname ‘eth0.2’
option force_link ‘1’
option proto ‘dhcp’

config interface ‘wan6’
option ifname ‘eth0.2’
option proto ‘dhcpv6’

config switch
option name ‘switch0’
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘switch0’
option vlan ‘2’
option ports ‘0 6t’

config switch_vlan
option device ‘switch0’
option vlan ‘1’
option ports ‘1 2 3 4 6t’