No sys upgrade image

I tried to build OpenWRT 15.05 with two methods:

both methods has the same (or similar) result:

-rw-r–r-- 1 root root 687 Oct 18 22:41 md5sums
-rw-r–r-- 1 root root 1966080 Oct 18 22:41 openwrt-ar71xx-generic-root.squashfs
-rw-r–r-- 1 root root 1769476 Oct 18 22:41 openwrt-ar71xx-generic-root.squashfs-64k
-rw-r–r-- 1 root root 1572188 Oct 18 22:41 openwrt-ar71xx-generic-uImage-gzip.bin
-rw-r–r-- 1 root root 1135934 Oct 18 22:41 openwrt-ar71xx-generic-uImage-lzma.bin
-rwxr-xr-x 1 root root 3426772 Oct 18 22:41 openwrt-ar71xx-generic-vmlinux.bin
-rwxr-xr-x 1 root root 3431836 Oct 18 22:41 openwrt-ar71xx-generic-vmlinux.elf
-rw-r–r-- 1 root root 1572864 Oct 18 22:41 openwrt-ar71xx-generic-vmlinux.gz
-rw-r–r-- 1 root root 1179648 Oct 18 22:41 openwrt-ar71xx-generic-vmlinux.lzma
-rwxr-xr-x 1 root root 1207897 Oct 18 22:41 openwrt-ar71xx-generic-vmlinux-lzma.elf
drwxr-xr-x 8 root root 4096 Oct 18 22:16 packages
-rw-r–r-- 1 root root 1087 Oct 18 22:41 sha256sums

There are no sysupgrade images.

What am I doing wrong?

Thank you in advance for help.


Hi, will check once we are back from exhibition.

Hi, just pushed the code to github. Pls sync.


I had tried, and unfortunately bricked my domino.
I will try to build minimal image configuration and sysupgrade on my second domino.

Is it possible, to include packages from domino-firmware repository (including kernel audio module) into openwrt-cc repository?

Thank you in advance.

Best regards, L.

Yes. It is possible.

Here is the instructions.

Some point:

  1. Use BB1407, as the configuration is for 1407 release.
  2. Make sure the patches applied successfully without error.
  3. You need to create a folder called “files” and put the contents of “root-files” to “files” folder
  4. “domino-pi” should be put as your openwrt/package/domino-pi. The same for other packages.


I know. In BB there are no problem. But in our project we need CC. And there is problem with dependencies under CC.

Best regards, L.

I see. Do you mean that the basic openwrt image built in cc doesn’t work? In openwrt, the default configuration has no wifi, no luci, but should have Ethernet. The subnet is

I need to try build the domino Pi firmware for CC.

Please try. I was able to compile image yesterday, but today I see error:

make[3]: Entering directory `/root/openwrt-cc-master/toolchain/gdb’
mkdir -p /root/openwrt-cc-master/dl
/root/openwrt-cc-master/scripts/ “/root/openwrt-cc-master/dl” “gdb-linaro-7.6-2013.05.tar.bz2” “816290b91cff03912320089d353e8a12” “
–2015-10-23 11:55:30--
Resolving (…
Connecting to (||:443… connected.
HTTP request sent, awaiting response… 404 NOT FOUND
2015-10-23 11:55:32 ERROR 404: NOT FOUND.

Download failed.
–2015-10-23 11:55:32--
Resolving (…
Connecting to (||:80… connected.
HTTP request sent, awaiting response… 404 Not Found
2015-10-23 11:55:32 ERROR 404: Not Found.

Download failed.
–2015-10-23 11:55:32--
Resolving (…
Connecting to (||:80… connected.
HTTP request sent, awaiting response… 404 Not Found
2015-10-23 11:55:32 ERROR 404: Not Found.

Download failed.

The error is a downloading error, which means you cannot download the gdb-linaro source code from the Internet. Sometimes the server is down and you need to try later

gdb is for debugging, right? I wonder why you need this package.

One solution is to copy the gdb-linaro-7.6-2013.05.tar.bz2 from your old openwrt/dl folder to your new folder. As you said you have built successfully, you must have this file downloaded in your old folder already.

I have done as you said. Build was successfully finished.

My procedure:

repository clone
make manuconfig
> set domino target
> no other changes
> copy linaro to dl/ after error

I flashed openwrt-ar71xx-generic-domino-squashfs-sysupgrade.bin by luci.

After reboot device is flashing constantly red led.

I have set 192.168.100, on my laptop, but there is no ethernet connection (ping, ssh) with my domino device.

In my opinion is bricked :frowning:

by default, the Ethernet is WAN and you cannot connect directly using your computer. You can connect the board to your router and use serial to change settings and install software.

No big deal. Can you wait until next week so that I can compile Pi firmware using OpenWrt CC1505?

what dependency problem do you have when you compile your own firmware based on CC with Domino Pi packages?


I have connected domino to router and still no reaction. Only red led with constant light.

I can wait. I really like domino, as concept and its quality. But unfortunately we need CC on them with all packages (especially gstreamer1)

Best regards, L.

Hi, have you been able to reflash your Domino? To recover from a problem flashing the firmware you really need to plug the Domino into a USB port on your PC so you can see the messages as it boots/fails. Once you have the output from it booting it will be much easier to determine what the next steps should be. You probably need to set up a TFTP server (Like SolarWinds on Windows) to serve up an image file for the Domino to boot or flash. I’m using DNSMasq on Linux and it works very well if you are running Linux.

I also have spent quite a bit of time compiling and configuring CC and after a lot of work I have a functional system. The steps to building on CC aren’t really very different that BB but it’s extremely easy to get the source tree into a state where you can no longer build images (Or the images don’t work), so I’ve gotten into the habit of creating a compressed tar of the tree before changing a few options and recompiling. Once you get your Domino booting again I can probably answer some questions if you run into issues with building/configuring CC. It is definitely preferable to using BB since there are a ton of packages that don’t have updated MD5 checksums in BB, making it impossible to download and build some packages automatically. You end up having to manually download the package into the dl directory since it thinks that the files are corrupt because the MD5 sums don’t match. --It doesn’t check the MD5 of already downloaded packages so that’s one way around the issue.


I compiled Domino Pi firmware using OpenWrt CC1505. Pls test.

Still missing some packages. I will recompile and update online next week.