"No Tethering device found" on MT1300

I’m trying to get USB tethering working with my MT1300 but the router is stuck on " No Tethering device found, Plug in your smartphone or USB Modem to start."

Here’s what I tried so far:

  • The same USB cable works perfectly fine with setting up USB tethering on my laptop
  • lsusb detects the device correctly (Bus 001 Device 006: ID 05c6:9024 Fairphone Fairphone 4 5G)
  • I updated the router to stable (3.216) first (no luck) and then to the latest beta firmware (4.3.2, no luck again).
  • Output from dmesg:
[ 1381.203804] usb 1-1: new high-speed USB device number 12 using xhci-mtk
[ 1381.410576] rndis_host 1-1:1.0 usb0: register 'rndis_host' at usb-1e1c0000.xhci-1, RNDIS device
[ 1381.450185] rndis_host 1-1:1.0 usb0: unregister 'rndis_host' usb-1e1c0000.xhci-1, RNDIS device

What device are you using the USB cable to connect to, iPhone or Android Phone? What is its model and OS version?

I’m using a Fairphone 4 with Android 12 (latest available update) installed.

You’re activating USB tethering on MT1300 on the same way as on your laptop?

I do have this as well sometimes and then it seems to be the usb port on the MT1300 that really needs proper insertion, as if the connection is a bit dodgy…

And just to be sure try another USB cable as well, it should not matter but I do see differences with individual USB 3.0 cables.

I tried multiple cables and have the same result. No tethering device found when I connect my Fairphone 4. Other phone I tried work fine.

I can think of two possibilities:

  • The router firmware is missing something
  • Fairphone 4 is missing something (usb tethering does, however, work with my Linux laptop)

Unfortunately, I’m at a loss.

I found a solution. Searching for the device id of my phone (05c6:9024, from lsusb) led me to an OpenWRT discussion: UF896 - Qualcomm MSM8916 LTE router ~384MiB RAM/2.4GiB flash, Android: OpenWrt? - For Developers - OpenWrt Forum

The solution is to edit /etc/usb-mode.json and remove these lines:

                "05c6:9024": {
                        "*": {
                                "t_vendor": 1478,
                                "t_product": [ 36901 ],
                                "mode": "StandardEject",
                                "msg": [  ]

After that I plugged my device again and I can tether without any issues.

1 Like