No valid VPN provider id when connecting Slate AX to Wireguard

I have a Slate AX (GL-ATX1800). It works and I can use it for internet normally. I wanted to connect it to a VPN using Wireguard.

Separately, I have a Wireguard server instance running for a while and it works fine with multiple peers. This is hosted on my own home server running on Docker on Ubuntu. When I scan the Wireguard QR code from my phone, add the network and it works. This is true also while connected to the Slate AX, and outside of the home network. I can use the Wireguard connection with no problems.

When I do the same on the glinet app (VPN on router > Wireguard > Configuration > Manual Configuration > Scan Configuration QR Code), the configuration is added and it’s virtually the same as the phone (except the peer / private key).

When I click “Start client”, I get an error saying “No valid vpn provider id”. When I click “Edit”,I do not see any field called “provider id” or alike and, as said, the configuration looks the same as it’s working on the phone directly.

Any thoughts or input on how to solve “no valid vpn provider id”?

Thanks in advance!

May I ask what your cell phone model is?

Sorry it is a bug. We can send out a fix.

Are you using andriod or iphone?

Thanks @danyuan.zhong and @alzhao .

I tried with 2 phones, both Android based.

One is a Google Pixel 5 running Android 14. The other one is a Xiaomi BlackShark 3 running JOYUI 12.5 (based on MIUI 12.5, which is based on Android 11).

The app version right now is 2.3.6. (I assume this is the same as when I tried before posting this, but I can’t 100% confirm that).

Is there an issue id or tracker where I can follow this fix?

Thanks again!

You can send an email to support at, refer to this thread.

Or I can send an email to you using the email you registerred in this forum.

We have fixed this bug, the latest package has been updated in our official website,
you can update to download and use it, thanks!

Thanks for confirming, @xiaohongxiu. Unfortunately, I need to update through the Play Store due to some device policy restrictions. Are there any plans of releasing this fix through the Play Store too? I can see the version is 2.3.6 and the file you linked is 2.3.6(157). Will you release the fix as 2.3.6 or wait until there’s a version change (2.3.7 or 2.4.0)? Thanks.

@alzhao I will send the email. Thanks for your help!

I have the same issue since upgrading to latest firmware (4.4.6 release 10) on slate plus A1300.

Have removed and added it twice.

Using app on iPhone 14

The workaround was fine for me. I accessed via Chrome to the router IP, then set up the VPN there. That created a first “manual provider”. I guess is what the app is complaining about - since the app did not create any VPN provider group while adding the configs. Once those VPN configs were set up, I was able to connect from the phone without any issues.