No WISP mode on AR300M with firmware OpenWrt 18.06.1


#1

I’ve update my AR300M with firmware file gl-ar300m-3.013-0128.tar.

Under repeater mode there’s no option for selecting WISP mode (as in earlier versions, e.g. 2.27).

Under LuCi->Network->Interfaces an interface WWAN is listed, but with the remark “Unsupported protocol type” and the option “[Install protocol extensions…]”.

Which protocols do I need to make WISP / WWAN working?

Thanks for reading and have a nice day.


#2

@Barney I see same problem but I read the doc here https://docs.gl-inet.com/en/3/setup/mini_router/internet/

It say in this doc

It works in WISP (Wireless Internet Service Provider) mode by default, which means that the router will create its own subnet and act as a firewall to protect you from the public network.

I maybe agree this working. Problem for me is wifi no exist in air for me so really I not sure but when I look at interface it say different subnet for WAN and LAN.

But I agree with you this would be better if default was not hidden. @alzhao maybe should know two peoples thinks this. If you hide defaults you have somethings like a Mac computer and that is most terrible.


#3

In v3.x firmware, Repeater mode is WISP mode, the two term is the same. While the WDS or Extender are available in MORE SETTINGS -> Network Mode, which are bridge mode.


#4

@kyson-lok

The doc say

In Repeater section, click Scan to search for the available wireless networks nearby.

But I no see “Repeater section” so please explain? I make Wifi server happen by us Luci but when I connect laptop to wireless it no have internet so there is problem with bridge. Maybe I need do in GL software?

Thank you.


#5

https://docs.gl-inet.com/en/3/setup/mini_router/internet/
The repeater section is in the part under repeater, doh!

All your problems are because you can’t see (for some reason) the proper section in the GL UI and are making (wrong) changes in Luci which then conflict with what you are trying to achieve.
As per my previous advice, reset the router or better, reload the firmware and start from scratch.

Edit: aha, I see from another post that you have done as I suggested and got it working now.


#6

No. Continue not see “Repeater Section” in v3. Only made happen a little on Luci but continue not have internet on Guest wifi.


#7

Sorry for my understanding. But I don’t know what you mean by “default settings”. What is really the problem of WISP? It is just in the first screen of control UI: scan -> choose ssid->connect


#8

@alzhao

It is not a problem. I think I am not explain very well. What is happen is @Barney say he not can find how make WISP working.

I say if he read doc he see WISP is default.

I say after that maybe alzhao will make say “WISP is default” in GL UI because if he no do this maybe other peoples are confused in future.


#9

Can you see this? If you can’t find it, what is the browser are you using for?

You need to install GL firmware.


#10

@kyson-lok

Okay finally someones tell me is on Internet page. Thank you. But no exist on my Internet page.

You need to install GL firmware.

I do this and I say SO MANY TIME that I install GL firmware newest version 3.13 before one week.

If I go “Internet” page I no see “Repeater” box like you have. I see “Cable” I see “Tethering” I see “3g/4g Modem.”

But maybe this because I already have connect to wifi from v2 firmware. I see “Repeater options” and if I click I see

“Auto detect Captive Portal” and this off but I can turn on

also I see

“Auto scan and reconnect” and this on.

What you recommend me please?


#11

The support DOC in my post above (post 5) clearly says “click internet”


#12

@glitch

The support DOC in my post above (post 5) clearly says “click internet”

I no see this when I look up but okay maybe you right and I no see. Okay you very smart. You have solve to make WISP working or only wanting to know you are smart?


#13

Thanks for the hint. I didn’t know about the docs for firmware v3.


#14

@Barney

Before I read this doc two weeks! I tell everyones on forum SO MANY TIME I read this doc. I tell @alzhao. I tell @kyson-lok. I tell everyones.

But doc say go “Repeater section” and I no see “Repeater section” on 3.013 firmwares. Why I must say same thing so many many many many time?

Yes thank you because you want help. But please reading what I say because is difficult I not receive help for how make WISP functioning.


#15

That was my problem. I didn’t expect the WISP mode in the Repeater configuration. For me Repeater Mode is extending an existing WLAN. The extended WLAN has the same SSID as the original WLAN.

In WISP mode there are two different WLANs with different SSIDs and the router routes the traffic between the two WLANS/networks in the same way as with a cable or a 3G/4G modem.

I flashed the firmware again (without keep settings) and everything is now working as expected. No need to install any protocols for WWAN.

Thanks to every relpyer and sorry for my late answering (was absent some days from home).

Have a nice day.


#16

@Barney I am apologize. This thread is one you make, not me. :slight_smile: So you not knowing I am have long problem with this.


#17

Maybe you can try other browser or wireless device. It might be caused by compatibility.


#18

@kyson-lok

Maybe you can try other browser or wireless device. It might be caused by compatibility.

Yes I do first. Is a different problem. Thank you.