Noivce - E3372 LTE HiLink tethered but no internet


I am a bit of a novice and am need of some help please !

I bought a GL-AR750S router to use when working remotely, which has the latest firmware (3.104). I have also just bought a Huawei E3372h-320 LTE USB stick, which when plugged in sets itself up under the “tethering option”, however I get the following message under the “Tethering” heading within the Admin Panel, and have no internet:

“Subnet conflicts. Please change LAN IP address. Set [this is linked to the router LAN option] LAN IP.”

If I change the router LAN IP it makes no difference, I still have no internet.

Can some one point me in the right direction to solve this please.

Many thanks in advance


If you change IP, e.g. from to, it must work.

You can reboot the router if you have any problem after change IP.

Met a lot of such cases. Just change IP and it works.

1 Like

Many thanks, I have changed the IP as suggested, and it has worked, which is fantastic !

Previously I was only changing the last number of the IP, but changing the last two has worked.

It was so frustrating as the the USB stick comes pre configured with (the exact same IP as the router) and as far as I could see there is see no way of changing it !

Thank you for replying, it is much appreciated !!

Best wishes



yes, had the same issue
but that means we are going through NAT 2 times, once with with the router, once with the usb key. this is why the key appears as tethering/eth and not usb in the interface.
the old 3372 could be changed to stick/modem mode by applying the stick firmware instead of the hi link (nat/router) firmware
in this case you would not need to change the subnet, and the performance would be better.
but the latest version 3372-320 seems more difficult to switch to stick mode/firmware. i am still searching how to do it.

Have you found anything? I have 2 different USB dongle and I can’t find how to change inside gateway IP address
First is usb Vodafone from Huawei brand and no setting LAN or DHCP, only DMZ. Default IP is
Second is type usb c Vodafone from ZTE brand and no setting LAN or DHCP, only DMZ. Default IP is
My Flint 2 router is I don’t want to change LAN in router, just these USB need hack to change IP😒

If I buy M.2 board from gl-inet and second device dig inside and take off small card m.2
Would be work with M.2 board? No IP conflict?

You will have to change the LAN network. Using the default network causes so much trouble while having advanced desires. :wink:

Just do it. It’s a bit of work but after it’s done you will be happy. Just change it to something - maybe

Just make sure xxx is not 1, 8, 9 or 178

1 Like

Thanks mate, I changed the main router LAN and DHCP all fixed. All devices are correct and my backup mobile network is working.

1 Like