Non responding MT300A

Hi there,

I have been using the GL-MT300A successfully as a reapeater since I bough it (approx. 5 months ago). In fact, tt worked fine until September one when I left for the weekend. When I came back (now), the MT300A seems bricked.

The Wi-Fi network the MT300A had been connected to has changed the security, which might have influenced the mini router, I guess.

Anyways, I tried to do a factory reset (8+ seconds) but nothing happened, not even the LEDs blinked. Same result for the UBoot procedure, where you press the reset button before powering the unit. All it does after getting power, is the two green and the one red LEDs stay on without blinking, as they should in pretty much all resetting scenarios.

Does any one have an idea what is going on? What I could try next?

When press and hold the reset button and powering on the devices, no LED is flashing?


No, the LEDs do not flash. What happens as soon as it is powered on is the first green LED turns on (no flashing), then momentarily afterwards the other two (green and red) LEDs turn on, again, no flashing.

The behavior is the same whether the reset button is pressed or not before powering, and also if the reset button is pressed for 8+ seconds after powering.

can you contact ?