[NOT SOLVED] GL-MT1300 can't connect to 5GHz network

Hello Everyone, I need help !!

(Since I can’t post multiple images because I’m a new user I had to use a different approach)

(SUMMARY without images)
I have a GL-MT1300 device and am it’s configured in “router mode”:
I live in the UK have a internet router provided by the ISP. I use the GL-MT1300 router to create another wireless network for my devices.
INTERNET ↔ ISP_ROUTER ↔ GL-MT1300 ↔ DEVICES (ex: phones, tablets, laptops)
Since the latest firmware update I’m unable to connect to my ISP_ROUTER with 5GHz:
It can only connect with 2.4GHz: (MYROUTER = ISP_ROUTER)
After troubleshooting and reading lots of posts (here and online) I’ve tried several things without any success.
It seems that the GL-MT1300 can only connect/see 5GHz channels under 48. Anything above that it can’t connect/see them. For example it can connect/see “DIRECT-6n-Android_9347” because its using channel 48 but it can connect to “MYROUTER” because it’s using channel 112:
I honestly don’t understand how the device can view MYROUTER in the “channel analysis” but fails to see it when using the “internet” connection page:
I’ve tried changing the file /etc/config/wireless via SSH to no success:
I then realised that the settings on that file (/etc/config/wireless) only affect the WIRELESS settings on the GL-MT1300 device:
I then tried changing the country code to US, TW, JP, DE and GB to no success:
According to this post all of then should work:
Wikipedia also states that a lot of country codes should work with channels above 48:

Can someone please help me connect to “MYROUTER” using 5GHz on channels above 48?

You changed you country code already, uhm.

I think gl-mt1300 has no DFS support. This means your channels are pretty limited (36-48 and 149-173).

(And I’m not sure about 149-173, that probably need a fairly recent kernel)

Due to lack of authentication, MT1300 is prohibited to switch to DFS channel (52~144). Please switch the channel of the ISP router.
If you have to use DFS channel, please purchase products that support DFS, you can see this symbol on the page of these products.

That’s a real problem for me since my ISP won’t allow users to configure channels manually.
We are stuck using “automatic mode” which I guess enforces DFS and prevents us from connecting the GL-MT1300 to channels above 48.
I guess I have two options:

Thank you for your help with this one. Truly appreciated.

You might try to nudge your ISP router to choose lower channel by disconnecting 5 GHz wifi antennas, if possible, during its startup. When it’s up and running, connect them again. Many such devices don’t scan later for a “better” channel and stick to the one that they pick on bootup. YMMV

That’s a nice tip lecmipahu. Thank you for your help.
Unfortunately the ISP_ROUTER doesn’t have exposed antennas and I can’t see how will I be able to accomplish that task even if I manage to open it:

Use a wired connection from mt1300 to the isp router

Brilliant bOcy !! The world needs savvy people like you !

They’re right, you know.

If you cannot unscrew antennas, you can always wrap the router in aluminium foil. (Ground the foil)