Older MT300N-V1 and AR750 on same network, cannot see each other?


I feel like there’s a step I am missing here, and it will probably be a noob mistake but here goes. I currently subscribe to a certain tier of Internet package through my cable provider, which requires that I use their - rather dated - gigabit router/gateway with built in N150 wireless. Although I am planning to run ethernet back to that router to wire in all my devices, right now, I have an MT300N (v1 with testing 3.x firmware) and an AR750 with 3.0 firmware, both operating in EXTENDER mode.

Prior to setting extender mode, I gave each mini-router device an IP in the 10.x.x.x range, away from the primary router’s default range, ( - but still in the same subnet. AR750 got a static ip of, MT300N got I disabled DHCP on both GL-INET devices, so the computers connected to them wouldn’t try to grab an IP from them, set each wireless radio to match the primary router’s SSID, disabled SSID broadcast, and set each computer for DHCP.

Once Extender was enabled, any connected devices dutifully picked up a DHCP address from the primary router. I can see and share computer resources, and shared folders and networked devices fine, even those connected to the respective mini-routers.

HOWEVER, computers connected to the AR750 cannot see the console or shared device of the MT300N and computer’s connected to the MT300N cannot reach the AR750s console IP. Also, no devices directly connected to WIFI can reach the console of either mini router ( or Any idea how I can resolve this?

Note that prior to changing my Internet service, my primary router was running DD-WRT and set as a WDS station, which made config easier. This is pretty easy too, for now, and since I am limited to 50Mb speed on my downloads, I am not impacted by keeping both devices routers in N mode for now. I just wish they could talk to each other. If the nature of Extender disables this ability, please let me know.

At the very least, I’d like to see a shared USB drive I have connected to the MT300N on computers connected to the AR750.

Thank you!

I think the problem is that the device may not be properly routed.
Can you share your network Settings and routing table?


Thank you. I agree it’s probably a routing issue. I will supply my actual routing table(s), in my next response, but clarify – do you need them from the MT300N and AR750 respectively? How would I dump them?

I do note that after entering extender mode, each router actually does pick up a DHCP address from the primary, but that is on the wwan interface, not the LAN. I have set the LAN IP of each router to the .50 and .55 static addresses.

So, since the router has two private IP addresses, on separate interfaces, do we have some sort of ARP conflict? And if that is the case, why is this working at all, minus the ability to see one router from the other?


you can get route table by ip route command.

In extender mode,the router will stop the DHCP service and the router can only be allocated from the primary route to IP, so there will be no ARP conflicts.

One more clarification - I need to SSH into each router and do the ip route command? And do you want them from a connected PC as well?

As for DHCP service, I am not referring to that - what I mean is, the wwan interface is a DHCP “client” of the primary router, whereas I also have the LAN interface set with a static IP address, so as to access each mini router from - at least for now - machines directly connected to them, I would like to bridge the LAN and WWAN, but I don’t think it’s possible without using LUCI or other custom config.

Okay, with no immediate replies, I have run IP ROUTE on each of my devices; output is below:

root@GL-AR750:~# ip route
default via dev br-lan proto static
default via dev wlan-sta proto static src metric 20 dev br-lan proto kernel scope link src dev wlan-sta proto static scope link metric 20

root@MT300N:~# ip route
default via dev br-lan proto static
default via dev wlan-sta proto static src metric 20 dev br-lan proto kernel scope link src dev wlan-sta proto static scope link metric 20

From a PC connected to MT300N:

IPv4 Route Table

Active Routes:
-------- Network_______ Destination Netmask ___Gateway Interface _______Metric
     20         On-link    276         On-link    276         On-link    276         On-link    306         On-link    306         On-link    306         On-link    306         On-link    276         On-link    306         On-link    276

Hope that’s readable.

The existence of these two rules will prevent your device from being properly routed, and the sent data packets will only form a loop in br-lan and will not be properly routed to wlan-sta.

These are not rules. These are the default routes when I:

  • Assign a static ip of to my GL-AR70 and…
  • Turn on EXTENDER mode. In extender mode, I have set a DHCP static lease so WWAN picks up

I have no static routes defined. Now what?

Anyone have a solution here? Have I found a bug?

Since you are connecting to your ISP’s router via Extended Mode (Wireless), check to ensure that AP isolation isn’t in place there.

Your setup is actually a bit complex - I’d walk it back to using ethernet at first - bridging the ISP’s device, and anchoring things on the AR-750 for the moment, letting it do the routing and other duties.

@sfx2000 My ISP’s device is a “crippled” TG862G; there is no APP isolution in place; and if there is, it’s permanently enabled, and I cannot find a way to disable it. I was actually looking to decrease the number of devices in my “chain” - earlier with a faster-speed package, I used a TP-Link router with DD-WRT and a standalone modem… since DD-WRT and my router supported WDS, it was easy to connect both the AR-750 AND MT300 in true bridge mode, and even using the 5gz radio on the AR750 for some isolation from other lower-spec wireless devices.

Now, with the combo modem/router, I have to deal with these issues, as described. It is true that I could put the combo router into bridge mode, introduce my router again as the primary, and use WDS as before. I also figured that extender would simplify things, but I am realizing now that while “an” extender lets you increase a wifi signal’s coverage, there is no real bridging involved; while my setup works, the fact that it does seems to be a freak of nature, since a true “wifi extender” would not allow what I am attempting.

I still would like to know, however from the devs how extender mode and WDS mode bridging differ in their hardware and in their implementation of OpenWRT, as I want to confirm that extender mode does not really bridge.