doesnt work when using GL-X300B-GPS doesn’t work when using GL-X300B-GPS when trying to access it. With same sim, and ZTE modem it works great, and without problems.

Please advise, as i think there is some setting in router. Please note that i enabled DMZ already, but it doesn’t work? Do i need a restart to make DMZ come into affect?

If you run the nslookup are there any results returned?

Yes, it gives 5 addresses back. Note that i checked what is happening with Wireshark, and it is listening on 443 port. I opened it up, didn’t work, then i let everything open for this one device? It is weird, as it opens up the page but cams of people are not loading.

You can check to see if the address returned is owned by I suspect there is DNS hijacking on your network, so you can try DNS encryption.

Umm… so page openes like normal, everything is normal just cams wont open? As i said, if i connect this card back to ZTE it works like it should? Where do i set DNS encryption and why do you think that is the problem here?

Please refer to the following link

Routers may have different DNS Settings if the carrier offers the same service, so I’ll let you try DNS encryption.
In addition, what is the current modem model for the X300B? Carriers may have restrictions on different device types.
You can also try specifying a TTL of 65 in manual Settings

How do i specify TTL 65? I have this one GL-X300B-78d.

Click Manual Settings in modem page, and you can see the ttl option in the post.

I see what is wrong now. Router assigns different PORT to my computer with every connection. How can i make port not shuffle with every new connection to user? Can this be fixed? So my computer, fixed IP, and fixed opened port?

In a router, the source port address is always random, but this should not affect network access. I think the TTL or MTU parameters most likely affect it.

Can i make it not change? Port i mean.

Under the current openwrt system, there is no way to fixed port.

This still didn’t do the job. What else can i do?

One interesting thing I noticed was that when I was parsing the omegle domain name properly, the DNS server returned me an IP of
I can access this address normally, even on the X300B.
But when I tried domain resolution with the X300B, I got the wrong address
After I configure DNS encryption, the domain name is resolved correctly

I want to confirm that you have tried DNS encryption and confirmed that it does not solve the problem?

It doesn’t work for me either whilst behind a VPN which also protects the DNS info. I’ve checked for DNS leaks and it always give the VPN info as its supposed to but Omegle says “Error connecting to server. Please try again”. I suspect they block my VPN IP due to previous misuse of their service by others under the same IP. I use a MangoV2 with binding protection enabled but I would never enable protection provided by Cloudflare. If they see you visit KiwiFarms they will dispatch a SWAT team to your grandma’s house.

Screen Shot 2023-02-28 at 03.54.19

I get this responses. DNS encryption and CloudFlare is working.

1 Like

Is it accessible now?

Yes. Everything works, just cam doesnt load with Collie - if i change modem it works fine with the same card.

I think your carrier is hijacking your DNS request. You can try asking the carrier to unblock it.

Why would it work on ZTE modem if that was the case?