Only one client is able to connect to creta sharing public wifi

I’m using a creta to create a private network from my apartments public network, so that my devices can easily talk to each other but not all the other devices on the public wifi. However, only one client device is able to connect at any given time, and once one is connected, no others are able to access the internet.

Is there a workaround to allow multiple devices to access the network?

Can you give some more information on your setup? Are you using WIFI for all your devices and your WAN, or are some devices connected via Ethernet. Did you add firewall rules? Are you using VPN?

If you are in router mode, all your device connected to the Creta should be able to talk to each other, and then be routed out the apartment WIFI.

Some devices are wired (my laptop and tv) others are wireless (Amazon echo, cell phone). I’m not currently using a VPN, no firewall rules, the configuration is pretty much default.

Thanks for helping me troubleshoot.

I own a Creta, and I’m currently on travel using my Slate, which is a very similar router. I have 5 devices with me that can all talk to each other, and can all go out the router at the place I am staying, and reach the internet. I am running the VPN client on my Slate right now, so I can have a US IP address, but I have many times in the past used both my Creta and my Slate without a VPN connection, with multiple systems connected to it, that could all reach the internet.

First thing I would do is to make sure your router’s firmware is up to date. The current stable firmware is: 3.212

The next thing is during trouble-shooting is to go into your Custom DNS Server screen, and turn everything off. Once we get the Creta working, you can turn back on what you want.


So… It was the DNS settings, I’d forgotten to turn off NextDNS.

Thanks for the help.

1 Like