Opal - disable link-local (FE80) IPv6 assignment

Hello, big fan of GLiNet and Goodcloud. I have two Mangoes and an Opal but I’m having trouble figuring out how to turn OFF link-local IPv6 assignment on the Opal. I’ve turned off every instance of IPv6 in the main router menu and on Luci plus disabling WAN6, unchecking all the boxes that mention IPV6 everywhere throughout all the menus. Still it assigns FE80 addresses in addition to IPv4s.

For reasons I won’t go into, I don’t want to use IPV6 at all, anywhere, at any time on this router (Opal). All WAN traffic is IPV4 and I want all LAN assignments to be purely IPV4 as well.

What am I missing?

This may be caused by wrong sysctl setting.
You can use the following command to check:

grep disable_ipv6 /etc/sysctl.d -nr

Use following to correct it:

cat >/etc/sysctl.d/99-disable-ipv6.conf <<EOF
1 Like

Thank you, I will try that.