Opal Router - Extender Mode not working?

Hi all,

I have just purchased an Opal (GL-SFT1200) router and updated the firmware to 3.216.

The network setup at home is as follows:

WEB → Modem → Router → End user devices

This works fine most of the time, but in specific rooms throughout the house we don’t get any WiFi signal.

I’ve purchased this router to act as a WiFi Extender, so I can place it centrally and boost the WiFi signal of my current WiFi network, so it can reach places my current main router can’t reach.

When I toggle on WiFi extender mode, choose my WiFi SSID and enter the password, I wait 5 mins for it to apply and I end up with 2 SSIDs. 1 UNBOOSTED SSID of my main router and another SSID for the Opal.

This isn’t the behaviour i was expecting.

What I want to achieve is 1 SSID, so my devices can successfully roam between my main router and the Opal router. I do not want 2 SSIDs.

Can anyone please provide any support?

Thanks

Once you have connected your Opal you need to login to it (it will have an IP address dished out by your main Modem/Router in extender mode so look in your client list on the main router) and change the WiFi SSID to match your main router details both SSID and password.

1 Like

Thanks for the reply.

I tried this.

So in the Opal, i disabled 2.4ghz (because my WiFi is 5ghz only) and changed the SSID of the 5ghz WiFi to match my routers SSID. Switched the device over to Extender mode and this had zero effect on the signal.

Are you saying that i need to repeat the above once I’ve turned on Extender mode?

No you shouldn’t have to. So if you login to the Opal, you see what SSID; the Opal or the one you changed to? Sounds like perhaps the SSID hasn’t stuck?

If worse comes to worse what I’d do (based on experience).

Reset your Opal ( Hold reset button until you get slow, faster, fastest flashing LEDs then release)
Login to Opal router (192.168.8.1) and set language and password
Set network mode to extender mode and attach to your main SSID.
Once extender mode is successful (check you can attach to “new” Opal SSID and get internets)
Check the IP address that your main router has given your Opal
Login to Opal router
Turn off 2.4Ghz on Opal
Rename SSID and Password on Opal to match your main router details.

Hopefully that will work :slight_smile:

1 Like

Thanks for the reply.

I’ll give this a try right now and I’ll reply back.

Oh and if you can, when changing things on the Opal after setup as extender mode, use a wired device. Just makes it a bit easier when mucking around and changing and attaching to SSIDs.

1 Like

Thanks for replying.

So I’ve done the following:

  • Reset the Opal by pressing the power button until it’s rapidly blinking
  • I configured a new password
  • I enabled extender mode, selected my SSID and entered the password
  • Waited for it to produce a solid white light
  • Checked my routers DHCP allocated IP for the Opal (192.168.1.119) https://i.imgur.com/jSO5coF.png
  • Entered that IP into Firefox and Edge on my wired desktop and i can’t access the Opal https://i.imgur.com/zo3wkXj.png
  • I’ve entered that IP address into Firefox on my phone and i can’t access the Opal
  • I can get a ping response from that IP address https ://i. imgur .com/XdiOuak.png
  • I’ve noticed that my router has a different mac address then the one listed on the box, however the router reports the correct device name

I’ll reset and try again.

Can you wire connect to the Opal?

1 Like

Thanks for replying.

When I attempted to Ethernet from the Opal to my Desktop (which is wired into the main router), i couldn’t access the Opal either. However i could browse the internet fine.

Just resetting the Opal again now.

Sorry I haven’t done this for a while. If you wire connect to the Opal after extender mode setup does 192.168.8.1 produce anything (make sure LAN port and not WAN port) ?

1 Like

Thanks for the reply.

I’ve just reset the Opal again (This time using my phone) and I’m getting the same results

  • DHCP IP is the same
  • I Can browse the web when i connect to the Opal SSID
  • I Can’t browse to the allocated 192.168.1.119 IP on my desktop or phone
  • I Can ping 192.168.1.119
  • Opal plugged directly into my desktop, I can browse the web fine
  • Opal plugged directly into my desktop, I can’t ping 192.168.1.119
  • Opal plugged directly into my desktop, I can’t access 192.168.1.119 or 192.168.8.1

Ok, I just fired up one of my Beryl MT1300s and it’s exhibiting the same symptomns you’re describing. I’m not sure if something has changed since I last tried this (maybe even under firmware 3.x.x) . I’m doing some playing, sorry if I’ve led you up the garden path…

1 Like

Thanks for replying.

I appreciate you taking your time to help me out.

Ok so I have just tried your original documented process:

  1. Turn off 2.4Ghz
  2. Rename 5Ghz to same as main router
  3. Go to extender mode

And I am now seeing my MT1300 presenting with my primary SSID the same as my main router (see bottom AP)

I cannot access the extender’s web interface either via the main network wired , direct wired connection or wireless.

This is with a Beryl and sadly I don’t have an Opal to do a complete duplicate test (given the different chipset, firmware etc)

Sorry.

1 Like

It‘s written in the settings that you won’t be able to access the GUI anymore when you enable extender mode. So this is usually the reason for it.

I fixed it by setting any-any routes for the zones within the firewall in luci.

DHCP reservation won’t work well because the MAC will change depending on the device behind the extender.

So tried the same method as yourself and got this result

Signal isn’t boosted and nothing has improved.